summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris McDonough <chrism@plope.com>2012-03-23 19:47:09 -0400
committerChris McDonough <chrism@plope.com>2012-03-23 19:47:09 -0400
commit16ac9dffa2a49b17969ded2610927d08fe25db23 (patch)
tree4fe8a0083a3d4eff90192693928cba780d7cbd41
parent5d74a94089367375512c9cd885411195e644e62c (diff)
downloadrepoze-lru-16ac9dffa2a49b17969ded2610927d08fe25db23.tar.gz
dont test under jython; this is just a testing race
-rw-r--r--tox.ini19
1 files changed, 15 insertions, 4 deletions
diff --git a/tox.ini b/tox.ini
index 58e0978..8c5d74e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,14 +1,25 @@
[tox]
envlist =
- py25,py26,py27,py32,jython,pypy
+ py25,py26,py27,py32,pypy
[testenv]
commands =
python setup.py test -q
-[testenv:jython]
-commands =
- jython setup.py test -q
+# timing race conditions in tests cause a test under Jython 2.5 to fail:
+
+#.F.......................
+#======================================================================
+#FAIL: When timeout is given, decorator must eventually forget entries
+#----------------------------------------------------------------------
+#Traceback (most recent call last):
+# File "/home/chrism/projects/repoze.lru/.tox/jython/Lib/site-packages/repoze/l#ru/tests.py", line 512, in test_expiry
+# self.assertTrue(stop - start > 0.1)
+#AssertionError
+
+#[testenv:jython]
+#commands =
+# jython setup.py test -q
# coverage reporting broken with namespace packages and pip/nose apparently.
# It's not a tox thing or is it related to setuptools vs. distribute; once