summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChayim <chayim@users.noreply.github.com>2021-10-26 14:13:20 +0300
committerGitHub <noreply@github.com>2021-10-26 14:13:20 +0300
commit866ac00b45a144753c40bb466e784a8917212172 (patch)
treef221d6b442dd6b2996911ab999a6e7b47d52b1bf
parent2b0a1e72b82b1706ae8f9939dab0ddd62efe413f (diff)
downloadredis-py-866ac00b45a144753c40bb466e784a8917212172.tar.gz
Fixing the package to include commands (#1649)v4.0.0b3
* Fixing the package to include commands. Fixes #1645
-rw-r--r--docs/conf.py152
-rw-r--r--redis/__init__.py2
-rw-r--r--setup.cfg39
-rw-r--r--setup.py43
4 files changed, 124 insertions, 112 deletions
diff --git a/docs/conf.py b/docs/conf.py
index 3eb3f33..dfdaf9e 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -16,212 +16,218 @@ import sys
# If extensions (or modules to document with autodoc) are in another directory,
# add these directories to sys.path here. If the directory is relative to the
# documentation root, use os.path.abspath to make it absolute, like shown here.
-#sys.path.insert(0, os.path.abspath('.'))
+# sys.path.insert(0, os.path.abspath('.'))
sys.path.append(os.path.abspath(os.path.pardir))
# -- General configuration ----------------------------------------------------
# If your documentation needs a minimal Sphinx version, state it here.
-#needs_sphinx = '1.0'
+# needs_sphinx = '1.0'
# Add any Sphinx extension module names here, as strings. They can be
# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.doctest', 'sphinx.ext.viewcode']
+extensions = [
+ "sphinx.ext.autodoc",
+ "sphinx.ext.doctest",
+ "sphinx.ext.viewcode"
+]
# Add any paths that contain templates here, relative to this directory.
-templates_path = ['_templates']
+templates_path = ["_templates"]
# The suffix of source filenames.
-source_suffix = '.rst'
+source_suffix = ".rst"
# The encoding of source files.
-#source_encoding = 'utf-8-sig'
+# source_encoding = 'utf-8-sig'
# The master toctree document.
-master_doc = 'index'
+master_doc = "index"
# General information about the project.
-project = 'redis-py'
-copyright = '2016, Andy McCurdy'
+project = "redis-py"
+copyright = "2016, Andy McCurdy"
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
# built documents.
#
# The short X.Y version.
-version = '2.10.5'
+version = "2.10.5"
# The full version, including alpha/beta/rc tags.
-release = '2.10.5'
+release = "2.10.5"
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
-#language = None
+# language = None
# There are two options for replacing |today|: either, you set today to some
# non-false value, then it is used:
-#today = ''
+# today = ''
# Else, today_fmt is used as the format for a strftime call.
-#today_fmt = '%B %d, %Y'
+# today_fmt = '%B %d, %Y'
# List of patterns, relative to source directory, that match files and
# directories to ignore when looking for source files.
-exclude_patterns = ['_build']
+exclude_patterns = ["_build"]
# The reST default role (used for this markup: `text`) to use for all
# documents.
-#default_role = None
+# default_role = None
# If true, '()' will be appended to :func: etc. cross-reference text.
-#add_function_parentheses = True
+# add_function_parentheses = True
# If true, the current module name will be prepended to all description
# unit titles (such as .. function::).
-#add_module_names = True
+# add_module_names = True
# If true, sectionauthor and moduleauthor directives will be shown in the
# output. They are ignored by default.
-#show_authors = False
+# show_authors = False
# The name of the Pygments (syntax highlighting) style to use.
-pygments_style = 'sphinx'
+pygments_style = "sphinx"
# A list of ignored prefixes for module index sorting.
-#modindex_common_prefix = []
+# modindex_common_prefix = []
# -- Options for HTML output --------------------------------------------------
# The theme to use for HTML and HTML Help pages. See the documentation for
# a list of builtin themes.
-html_theme = 'default'
+html_theme = "default"
# Theme options are theme-specific and customize the look and feel of a theme
# further. For a list of options available for each theme, see the
# documentation.
-#html_theme_options = {}
+# html_theme_options = {}
# Add any paths that contain custom themes here, relative to this directory.
-#html_theme_path = []
+# html_theme_path = []
# The name for this set of Sphinx documents. If None, it defaults to
# "<project> v<release> documentation".
-#html_title = None
+# html_title = None
# A shorter title for the navigation bar. Default is the same as html_title.
-#html_short_title = None
+# html_short_title = None
# The name of an image file (relative to this directory) to place at the top
# of the sidebar.
-#html_logo = None
+# html_logo = None
# The name of an image file (within the static path) to use as favicon of the
# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
# pixels large.
-#html_favicon = None
+# html_favicon = None
# Add any paths that contain custom static files (such as style sheets) here,
# relative to this directory. They are copied after the builtin static files,
# so a file named "default.css" will overwrite the builtin "default.css".
-html_static_path = ['_static']
+html_static_path = ["_static"]
# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
# using the given strftime format.
-#html_last_updated_fmt = '%b %d, %Y'
+# html_last_updated_fmt = '%b %d, %Y'
# If true, SmartyPants will be used to convert quotes and dashes to
# typographically correct entities.
-#html_use_smartypants = True
+# html_use_smartypants = True
# Custom sidebar templates, maps document names to template names.
-#html_sidebars = {}
+# html_sidebars = {}
# Additional templates that should be rendered to pages, maps page names to
# template names.
-#html_additional_pages = {}
+# html_additional_pages = {}
# If false, no module index is generated.
-#html_domain_indices = True
+# html_domain_indices = True
# If false, no index is generated.
-#html_use_index = True
+# html_use_index = True
# If true, the index is split into individual pages for each letter.
-#html_split_index = False
+# html_split_index = False
# If true, links to the reST sources are added to the pages.
-#html_show_sourcelink = True
+# html_show_sourcelink = True
# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
-#html_show_sphinx = True
+# html_show_sphinx = True
# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
-#html_show_copyright = True
+# html_show_copyright = True
# If true, an OpenSearch description file will be output, and all pages will
# contain a <link> tag referring to it. The value of this option must be the
# base URL from which the finished HTML is served.
-#html_use_opensearch = ''
+# html_use_opensearch = ''
# This is the file name suffix for HTML files (e.g. ".xhtml").
-#html_file_suffix = None
+# html_file_suffix = None
# Output file base name for HTML help builder.
-htmlhelp_basename = 'redis-pydoc'
+htmlhelp_basename = "redis-pydoc"
# -- Options for LaTeX output -------------------------------------------------
latex_elements = {
# The paper size ('letterpaper' or 'a4paper').
- #'papersize': 'letterpaper',
-
+ # 'papersize': 'letterpaper',
# The font size ('10pt', '11pt' or '12pt').
- #'pointsize': '10pt',
-
+ # 'pointsize': '10pt',
# Additional stuff for the LaTeX preamble.
- #'preamble': '',
+ # 'preamble': '',
}
# Grouping the document tree into LaTeX files. List of tuples
# (source start file, target name, title, author, documentclass
# [howto/manual]).
latex_documents = [
- ('index', 'redis-py.tex', 'redis-py Documentation',
- 'Andy McCurdy', 'manual'),
+ ("index",
+ "redis-py.tex",
+ "redis-py Documentation",
+ "Andy McCurdy",
+ "manual"),
]
# The name of an image file (relative to this directory) to place at the top of
# the title page.
-#latex_logo = None
+# latex_logo = None
# For "manual" documents, if this is true, then toplevel headings are parts,
# not chapters.
-#latex_use_parts = False
+# latex_use_parts = False
# If true, show page references after internal links.
-#latex_show_pagerefs = False
+# latex_show_pagerefs = False
# If true, show URL addresses after external links.
-#latex_show_urls = False
+# latex_show_urls = False
# Documents to append as an appendix to all manuals.
-#latex_appendices = []
+# latex_appendices = []
# If false, no module index is generated.
-#latex_domain_indices = True
+# latex_domain_indices = True
# -- Options for manual page output -------------------------------------------
# One entry per manual page. List of tuples
# (source start file, name, description, authors, manual section).
-man_pages = [
- ('index', 'redis-py', 'redis-py Documentation',
- ['Andy McCurdy'], 1)
-]
+man_pages = [(
+ "index",
+ "redis-py",
+ "redis-py Documentation",
+ ["Andy McCurdy"], 1)]
# If true, show URL addresses after external links.
-#man_show_urls = False
+# man_show_urls = False
# -- Options for Texinfo output -----------------------------------------------
@@ -230,21 +236,27 @@ man_pages = [
# (source start file, target name, title, author,
# dir menu entry, description, category)
texinfo_documents = [
- ('index', 'redis-py', 'redis-py Documentation',
- 'Andy McCurdy', 'redis-py',
- 'One line description of project.', 'Miscellaneous'),
+ (
+ "index",
+ "redis-py",
+ "redis-py Documentation",
+ "Andy McCurdy",
+ "redis-py",
+ "One line description of project.",
+ "Miscellaneous",
+ ),
]
# Documents to append as an appendix to all manuals.
-#texinfo_appendices = []
+# texinfo_appendices = []
# If false, no module index is generated.
-#texinfo_domain_indices = True
+# texinfo_domain_indices = True
# How to display URL addresses: 'footnote', 'no', or 'inline'.
-#texinfo_show_urls = 'footnote'
+# texinfo_show_urls = 'footnote'
-epub_title = 'redis-py'
-epub_author = 'Andy McCurdy'
-epub_publisher = 'Andy McCurdy'
-epub_copyright = '2011, Andy McCurdy'
+epub_title = "redis-py"
+epub_author = "Andy McCurdy"
+epub_publisher = "Andy McCurdy"
+epub_copyright = "2011, Andy McCurdy"
diff --git a/redis/__init__.py b/redis/__init__.py
index 3e7831e..2458b5b 100644
--- a/redis/__init__.py
+++ b/redis/__init__.py
@@ -31,7 +31,7 @@ def int_or_str(value):
return value
-__version__ = '4.0.0b2'
+__version__ = '4.0.0b3'
VERSION = tuple(map(int_or_str, __version__.split('.')))
__all__ = [
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index a9c9849..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,39 +0,0 @@
-[metadata]
-name = redis
-version = attr: redis.__version__
-description = Python client for Redis key-value store
-long_description = file: README.rst
-url = https://github.com/andymccurdy/redis-py
-author = Andy McCurdy
-author_email = sedrik@gmail.com
-maintainer = Andy McCurdy
-maintainer_email = sedrik@gmail.com
-keywords = Redis, key-value store
-license = MIT
-classifiers =
- Development Status :: 5 - Production/Stable
- Environment :: Console
- Intended Audience :: Developers
- License :: OSI Approved :: MIT License
- Operating System :: OS Independent
- Programming Language :: Python
- Programming Language :: Python :: 3
- Programming Language :: Python :: 3 :: Only
- Programming Language :: Python :: 3.5
- Programming Language :: Python :: 3.6
- Programming Language :: Python :: 3.7
- Programming Language :: Python :: 3.8
- Programming Language :: Python :: 3.9
- Programming Language :: Python :: Implementation :: CPython
- Programming Language :: Python :: Implementation :: PyPy
-
-
-[options]
-packages = redis
-python_requires = >=3.5
-
-[options.extras_require]
-hiredis = hiredis>=0.1.3
-
-[flake8]
-exclude = .venv,.tox,dist,docs,build,*.egg,redis_install,env,venv,.undodir
diff --git a/setup.py b/setup.py
index c823345..50c3d91 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,43 @@
#!/usr/bin/env python
-from setuptools import setup
+from setuptools import setup, find_packages
+import redis
-setup()
+setup(
+ name="redis",
+ description="Python client for Redis database and key-value store",
+ long_description=open("README.md").read().strip(),
+ keywords=["Redis", "key-value store", "database"],
+ license="MIT",
+ version=redis.__version__,
+ packages=find_packages(
+ include=[
+ "redis",
+ "redis.commands",
+ "redis.commands.json",
+ "redis.commands.search",
+ ]
+ ),
+ url="https://github.com/redis/redis-py",
+ author="Redis Inc.",
+ author_email="oss@redis.com",
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Console",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3 :: Only",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ ],
+ extras_require={
+ "hiredis": ["hiredis>=1.0.0"],
+ },
+)