summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordvora-h <67596500+dvora-h@users.noreply.github.com>2022-05-09 15:55:47 +0300
committerGitHub <noreply@github.com>2022-05-09 15:55:47 +0300
commit42b937fa1f73f3e8251eba5ec8ead2fcbaec7c50 (patch)
tree78725fabd974df1f291cc49cf2f87c2fa64b2ec1
parentc51435d92a8bed246f1c9ad9284c8543fca5d1e0 (diff)
downloadredis-py-42b937fa1f73f3e8251eba5ec8ead2fcbaec7c50.tar.gz
fix import (#2175)v4.3.1
-rw-r--r--redis/commands/search/__init__.py3
-rw-r--r--setup.py2
2 files changed, 3 insertions, 2 deletions
diff --git a/redis/commands/search/__init__.py b/redis/commands/search/__init__.py
index bcad785..b1c0e8b 100644
--- a/redis/commands/search/__init__.py
+++ b/redis/commands/search/__init__.py
@@ -1,5 +1,6 @@
import redis
+from ...asyncio.client import Pipeline as AsyncioPipeline
from .commands import AsyncSearchCommands, SearchCommands
@@ -174,5 +175,5 @@ class Pipeline(SearchCommands, redis.client.Pipeline):
"""Pipeline for the module."""
-class AsyncPipeline(AsyncSearchCommands, redis.asyncio.client.Pipeline):
+class AsyncPipeline(AsyncSearchCommands, AsyncioPipeline):
"""AsyncPipeline for the module."""
diff --git a/setup.py b/setup.py
index 9b96276..1638799 100644
--- a/setup.py
+++ b/setup.py
@@ -8,7 +8,7 @@ setup(
long_description_content_type="text/markdown",
keywords=["Redis", "key-value store", "database"],
license="MIT",
- version="4.3.0",
+ version="4.3.1",
packages=find_packages(
include=[
"redis",