summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChayim <chayim@users.noreply.github.com>2021-11-04 13:55:33 +0200
committerGitHub <noreply@github.com>2021-11-04 13:55:33 +0200
commit9804bdc52bdf4e85e66ae11246453be5dc40a9c0 (patch)
tree705b45121a1fe8b51b75c9e5a799ae3784848e5f
parent8d3c61598706eb049caa66a23501018f2f416673 (diff)
downloadredis-py-9804bdc52bdf4e85e66ae11246453be5dc40a9c0.tar.gz
publish to pypi as releases are generated with the release drafter (#1647)v4.0.0rc1
-rw-r--r--.github/workflows/pypi-publish.yaml31
1 files changed, 31 insertions, 0 deletions
diff --git a/.github/workflows/pypi-publish.yaml b/.github/workflows/pypi-publish.yaml
new file mode 100644
index 0000000..b842c36
--- /dev/null
+++ b/.github/workflows/pypi-publish.yaml
@@ -0,0 +1,31 @@
+name: Publish tag to Pypi
+
+on:
+ release:
+ types: [published]
+
+jobs:
+
+ build_and_package:
+ runs-on: ubuntu-latest
+ steps:
+ - uses: actions/checkout@v2
+ - name: install python
+ uses: actions/setup-python@v2
+ with:
+ python-version: 3.0
+ - name: Install dev tools
+ run: |
+ pip install -r dev_requirements.txt
+ pip install twine wheel
+
+ - name: Build package
+ run: |
+ python setup.py build
+ python setup.py dist bdist_wheel
+
+ - name: Publish to Pypi
+ uses: pypa/gh-action-pypi-publish@release/v1
+ with:
+ user: __token__
+ password: ${{ secrets.PYPI_API_TOKEN }}