summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy McCurdy <andy@andymccurdy.com>2014-06-01 22:01:18 -0700
committerAndy McCurdy <andy@andymccurdy.com>2014-06-01 22:01:18 -0700
commita9162f5c15fb39e985b9793b74dea1e2760c3a6b (patch)
treefc9d8e54857bf3c937dce77a9c33a924de2469b5
parentdba0e320b691d3af1ba0b8ad68aab0c06e296043 (diff)
downloadredis-py-a9162f5c15fb39e985b9793b74dea1e2760c3a6b.tar.gz
update travis config to test against python 3.4
-rw-r--r--.travis.yml9
1 files changed, 5 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index 8b56c95..8544d02 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,5 +1,6 @@
language: python
python:
+ - "3.4"
- "3.3"
- "3.2"
- "2.7"
@@ -10,13 +11,13 @@ env:
- TEST_HIREDIS=0
- TEST_HIREDIS=1
install:
- - pip install -e . --use-mirrors
- - "if [[ $TEST_PEP8 == '1' ]]; then pip install pep8 --use-mirrors; fi"
- - "if [[ $TEST_HIREDIS == '1' ]]; then pip install hiredis --use-mirrors; fi"
+ - pip install -e .
+ - "if [[ $TEST_PEP8 == '1' ]]; then pip install pep8; fi"
+ - "if [[ $TEST_HIREDIS == '1' ]]; then pip install hiredis; fi"
script: "if [[ $TEST_PEP8 == '1' ]]; then pep8 --repeat --show-source --exclude=.venv,.tox,dist,docs,build,*.egg .; else python setup.py test; fi"
matrix:
include:
- python: "2.7"
env: TEST_PEP8=1
- - python: "3.3"
+ - python: "3.4"
env: TEST_PEP8=1