summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy McCurdy <andy@andymccurdy.com>2014-05-29 12:57:16 -0700
committerAndy McCurdy <andy@andymccurdy.com>2014-05-29 12:57:16 -0700
commit3aecfe3a516fcb74c39e0183fddbbd1dff6bcb9a (patch)
treea8e5e7f94be3b800973f8a11a6fd52d6fd7eb061
parentce02a2eaf6e70af3b1789d73fa9c569c84d35449 (diff)
downloadredis-py-3aecfe3a516fcb74c39e0183fddbbd1dff6bcb9a.tar.gz
test against Python 3.4 with tox. note 3.4.0 has issues, use 3.4.1 instead
-rw-r--r--setup.py1
-rw-r--r--tox.ini9
2 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 45358b4..67706f1 100644
--- a/setup.py
+++ b/setup.py
@@ -56,5 +56,6 @@ setup(
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
]
)
diff --git a/tox.ini b/tox.ini
index 0b6f4ce..18e5046 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26, py27, py32, py33, hi26, hi27, hi32, hi33, pep8
+envlist = py26, py27, py32, py33, py34, hi26, hi27, hi32, hi33, hi34, pep8
[testenv]
deps=pytest>=2.5.0
@@ -33,6 +33,13 @@ deps =
pytest>=2.5.0
commands = py.test []
+[testenv:hi34]
+basepython = python3.4
+deps =
+ hiredis>=0.1.3
+ pytest>=2.5.0
+commands = py.test []
+
[testenv:pep8]
deps = pep8
commands = pep8 --repeat --show-source --exclude=.venv,.tox,dist,docs,build,*.egg .