summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.travis.yml b/.travis.yml
index a318a20c..f7b910d0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -17,13 +17,13 @@ before_install:
- bash .travis.fuseki_install_optional.sh
install:
- # iodate0.4.8 is problematic with Pypy, use fixed version
- - if [[ $TRAVIS_PYTHON_VERSION == '2.5' ]]; then pip install --default-timeout 60 ordereddict; pip install --default-timeout 60 "simplejson"; pip install --default-timeout 60 "elementtree"; pip install --default-timeout 60 "html5lib==0.95"; fi
- - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install --default-timeout 60 ordereddict; fi
- if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then pip install --default-timeout 60 -r requirements.py2.txt; pip install --default-timeout 60 "html5lib";fi
- if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '3' ]]; then pip install --default-timeout 60 -r requirements.py3.txt; fi
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install --default-timeout 60 ordereddict 'networkx<1.10' ; fi
+ - if [[ $TRAVIS_PYTHON_VERSION != '2.6' ]]; then pip install --default-timeout 60 networkx ; fi
+ # isodate0.4.8 is problematic with Pypy, use fixed version
- if [[ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then pip install --upgrade "https://bitbucket.org/gjhiggins/isodate/downloads/isodate-0.4.8.tar.gz"; pip install --default-timeout 60 "elementtree"; fi
- - if [[ $TRAVIS_PYTHON_VERSION != '2.5' ]]; then pip install --default-timeout 60 coverage coveralls nose-timer networkx && export HAS_COVERALLS=1; fi
+ - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
- python setup.py install
before_script: