diff options
author | Gunnar Aastrand Grimnes <gromgull@gmail.com> | 2013-03-23 20:09:33 +0100 |
---|---|---|
committer | Gunnar Aastrand Grimnes <gromgull@gmail.com> | 2013-03-23 20:09:33 +0100 |
commit | a073c486705a580961a799a6b8806059b9d889c2 (patch) | |
tree | 9a76ebc298ae5b9f89a15179946d3655bf89f424 /setup.py | |
parent | fc918ca1a1cf08e26cd0b270c085f7efbed92a7a (diff) | |
download | rdflib-a073c486705a580961a799a6b8806059b9d889c2.tar.gz |
dependencies for 2.6/2.5
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -52,10 +52,18 @@ else: kwargs['install_requires'] = [ 'isodate', 'html5lib', 'pyparsing<=1.5.7', 'SPARQLWrapper'] + + if sys.version_info[1]<7: + kwargs['install_requires'].append('ordereddict') + if sys.version_info[1]<6: + kwargs['install_requires'].append('simplejson') + except ImportError: from distutils.core import setup + + # Find version. We have to do this because we can't import it in Python 3 until # its been automatically converted in the setup process. def find_version(filename): |