summaryrefslogtreecommitdiff
path: root/CHANGELOG.md
diff options
context:
space:
mode:
authorgromgull <gromgull@gmail.com>2013-05-22 13:28:59 +0200
committergromgull <gromgull@gmail.com>2013-05-22 13:28:59 +0200
commit95c6e93b711f2a82d55fd2649682af9b565f79cd (patch)
tree0b05813f95ab76a956d1630ac8b19dc9cf828c51 /CHANGELOG.md
parentf36061f62c18b6347a89780ceb3322fe5455067f (diff)
downloadrdflib-95c6e93b711f2a82d55fd2649682af9b565f79cd.tar.gz
release 4.0.14.0.1
Diffstat (limited to 'CHANGELOG.md')
-rw-r--r--CHANGELOG.md36
1 files changed, 33 insertions, 3 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 2cc36a2f..37196fa5 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,4 +1,32 @@
-2013/06/16 RELEASE 4.0
+2013/05/22 RELEASE 4.0.1
+========================
+
+ Following RDFLib tradition, some bugs snuck into the 4.0 release.
+ This is a bug-fixing release:
+
+ * the new URI validation caused lots of problems, but is
+ nescessary to avoid ''RDF injection'' vulnerabilities. In the
+ spirit of ''be liberal in what you accept, but conservative in
+ what you produce", we moved validation to serialisation time.
+
+ * the ```rdflib.tools``` package was missing from the
+ ```setup.py``` script, and was therefore not included in the
+ PYPI tarballs.
+
+ * RDF parser choked on empty namespace URI
+ [#288](https://github.com/RDFLib/rdflib/issues/288)
+
+ * Parsing from ```sys.stdin``` was broken
+ [#285](https://github.com/RDFLib/rdflib/issues/285)
+
+ * The new IO store had problems with concurrent modifications if
+ several graphs used the same store
+ [#286](https://github.com/RDFLib/rdflib/issues/286)
+
+ * Moved HTML5Lib dependency to the recently released 1.0b1 which
+ support python3
+
+2013/05/16 RELEASE 4.0
======================
This release includes several major changes:
@@ -46,14 +74,16 @@ This release includes several major changes:
print row.age, row["name"]
```
-* "Slicing" of Graphs and Resources as syntactic sugar: ([#271](https://github.com/RDFLib/rdflib/issues/271))
+* "Slicing" of Graphs and Resources as syntactic sugar:
+ ([#271](https://github.com/RDFLib/rdflib/issues/271))
```py
graph[bob : FOAF.knows/FOAF.name]
-> generator over the names of Bobs friends
```
-* The ```SPARQLStore``` and ```SPARQLUpdateStore``` are now included in the RDFLib core
+* The ```SPARQLStore``` and ```SPARQLUpdateStore``` are now included
+ in the RDFLib core
* The documentation has been given a major overhaul, and examples
for most features have been added.