summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authort0b3 <t0b3@users.noreply.github.com>2020-04-25 12:12:24 +0200
committert0b3 <thomas.bettler@gmail.com>2020-04-26 10:38:18 +0200
commit02c6c01f77bcb7ca7104c93183cffffb121202ff (patch)
tree4fd0c5079e37ea0c659ea343559d8899105f86b5
parent3f0401dc527ef70abb1f0b76bdd281972ae2655c (diff)
downloadrdflib-02c6c01f77bcb7ca7104c93183cffffb121202ff.tar.gz
add python 3.8, drop python 2 and 3.4
Closes: https://github.com/RDFLib/rdflib/issues/1014 Signed-off-by: t0b3 <thomas.bettler@gmail.com>
-rw-r--r--.travis.yml9
-rw-r--r--rdflib/extras/external_graph_libs.py2
-rw-r--r--setup.py5
-rw-r--r--tox.ini4
4 files changed, 8 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index f37f0750..2d2ada1d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,5 +1,4 @@
# http://travis-ci.org/#!/RDFLib/rdflib
-sudo: false
language: python
branches:
only:
@@ -10,16 +9,14 @@ git:
depth: 3
python:
- - 2.7
- - 3.4
- 3.5
- 3.6
+ - 3.7
-matrix:
+jobs:
include:
- - python: 3.7
+ - python: 3.8
dist: xenial
- sudo: true
before_install:
- pip install -U setuptools pip # seems travis comes with a too old setuptools for html5lib
diff --git a/rdflib/extras/external_graph_libs.py b/rdflib/extras/external_graph_libs.py
index 8617b370..25c745c0 100644
--- a/rdflib/extras/external_graph_libs.py
+++ b/rdflib/extras/external_graph_libs.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python2.7
+#!/usr/bin/env
# encoding: utf-8
from __future__ import absolute_import
from __future__ import division
diff --git a/setup.py b/setup.py
index c115f068..8bba18d2 100644
--- a/setup.py
+++ b/setup.py
@@ -43,15 +43,14 @@ setup(
url="https://github.com/RDFLib/rdflib",
license="BSD-3-Clause",
platforms=["any"],
+ python_requires='>=3.5',
classifiers=[
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
"License :: OSI Approved :: BSD License",
"Topic :: Software Development :: Libraries :: Python Modules",
"Operating System :: OS Independent",
diff --git a/tox.ini b/tox.ini
index ee712287..b5b588fb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py34,py35,py36
+ py35,py36,py37,py38
[testenv]
setenv =
@@ -20,7 +20,7 @@ deps =
[testenv:cover]
basepython =
- python2.7
+ python3.7
commands =
{envpython} run_tests.py --where=./ \
--with-coverage --cover-html --cover-html-dir=./coverage \