summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörn Hees <joernhees@users.noreply.github.com>2016-07-27 02:44:53 +0200
committerGitHub <noreply@github.com>2016-07-27 02:44:53 +0200
commit8f5da1bc7bcb5ae204706b0bf8d19707eb06beb1 (patch)
tree6f4669c2eb07d5b1aedee735be2b81d593dcaa21
parente41617bf7eec79ae211f048845840c9786b06a2e (diff)
parentbce67bbab2fce21769ee61c3eb3f93ec85c36740 (diff)
downloadrdflib-8f5da1bc7bcb5ae204706b0bf8d19707eb06beb1.tar.gz
Merge pull request #641 from joernhees/fix_travis
travis and dependencies fixed
-rw-r--r--.travis.fuseki_install_optional.sh6
-rw-r--r--.travis.yml10
-rw-r--r--requirements.py2.txt3
-rw-r--r--requirements.py3.txt6
4 files changed, 15 insertions, 10 deletions
diff --git a/.travis.fuseki_install_optional.sh b/.travis.fuseki_install_optional.sh
index defdf29d..49e91f2c 100644
--- a/.travis.fuseki_install_optional.sh
+++ b/.travis.fuseki_install_optional.sh
@@ -2,11 +2,11 @@
set -v
-uri="http://archive.eu.apache.org/dist/jena/binaries/jena-fuseki1-1.1.2-distribution.tar.gz"
+uri="http://archive.apache.org/dist/jena/binaries/apache-jena-fuseki-2.4.0.tar.gz"
if wget "$uri" &&
- tar -zxf jena-fuseki*-distribution.tar.gz &&
- mv jena-fuseki*/ fuseki &&
+ tar -zxf *jena*fuseki*.tar.gz &&
+ mv *jena*fuseki*/ fuseki &&
cd fuseki ; then
# normal SPARQLStore & Dataset tests:
bash fuseki-server --port 3030 --debug --update --mem /db &>fuseki.log &
diff --git a/.travis.yml b/.travis.yml
index 4901b1ea..a22cf0cb 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,10 +1,13 @@
# http://travis-ci.org/#!/RDFLib/rdflib
-language: python
sudo: false
+language: python
branches:
only:
+ # only build master and release branches (merge request are built anyhow)
- master
- /^\d+\.\d+\.\d+(-.*)?$/
+git:
+ depth: 3
python:
# - 2.5
@@ -17,10 +20,11 @@ python:
# - "pypy"
before_install:
+ - pip install -U setuptools pip # seems travis comes with a too old setuptools for html5lib
- bash .travis.fuseki_install_optional.sh
install:
- - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then pip install --default-timeout 60 -r requirements.py2.txt; pip install --default-timeout 60 "html5lib";fi
+ - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then pip install --default-timeout 60 -r requirements.py2.txt; fi
- if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '3' ]]; then pip install --default-timeout 60 -r requirements.py3.txt; fi
- if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install --default-timeout 60 ordereddict 'networkx<1.10' ; fi
- if [[ $TRAVIS_PYTHON_VERSION != '2.6' ]]; then pip install --default-timeout 60 networkx ; fi
@@ -30,7 +34,7 @@ install:
- python setup.py install
before_script:
- - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then flake8 --exclude=pyRdfa,extras,host,transform,rdfs,sparql,results,pyMicrodata --exit-zero rdflib; fi
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.7' ]] || [[ $TRAVIS_PYTHON_VERSION == '3.5' ]]; then flake8 --exclude=pyRdfa,extras,host,transform,rdfs,sparql,results,pyMicrodata --exit-zero rdflib; fi
script:
# Must run the tests in build/src so python3 doesn't get confused and run
diff --git a/requirements.py2.txt b/requirements.py2.txt
index 4a8584d2..3da97d62 100644
--- a/requirements.py2.txt
+++ b/requirements.py2.txt
@@ -1,4 +1,5 @@
flake8
+html5lib==1.0b8
isodate
pyparsing<=1.5.7
-SPARQLWrapper>=1.6.2
+SPARQLWrapper
diff --git a/requirements.py3.txt b/requirements.py3.txt
index c48e8346..5005d8bf 100644
--- a/requirements.py3.txt
+++ b/requirements.py3.txt
@@ -1,5 +1,5 @@
-pyparsing
flake8
-html5lib
+html5lib==1.0b8
isodate
-SPARQLWrapper>=1.6.2
+pyparsing
+SPARQLWrapper