summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Car <nicholas.car@surroundaustralia.com>2021-04-10 13:07:34 +1000
committerGitHub <noreply@github.com>2021-04-10 13:07:34 +1000
commit45034056789fb0efff37f632e52d9d564f5d957b (patch)
tree6f5f544117955d7307960774d7dc1c10372b5808
parentd717cef505b07556fffc9f0e64d6c8f5b3a5b84c (diff)
parent69e5e26cabe338dbfedda5d32b12989c57a8995f (diff)
downloadrdflib-45034056789fb0efff37f632e52d9d564f5d957b.tar.gz
Merge pull request #1286 from white-gecko/feature/addDocuAboutLocalInstall
Add notes about how to install from git
-rw-r--r--README.md13
1 files changed, 13 insertions, 0 deletions
diff --git a/README.md b/README.md
index 7b3317cc..a8478ffc 100644
--- a/README.md
+++ b/README.md
@@ -45,6 +45,19 @@ Index (PyPI) at https://pypi.python.org/pypi/rdflib
The current version of RDFLib is 5.0.0, see the ``CHANGELOG.md``
file for what's new in this release.
+### Installation of the current master branch (for developers)
+
+With *pip* you can also install rdflib from the git repository with one of the following options:
+
+ $ pip install git+https://github.com/rdflib/rdflib@master
+ # or
+ $ pip install -e git+https://github.com/rdflib/rdflib@master#egg=rdflib
+
+or from your locally cloned repository you can install it with one of the following options:
+
+ $ python setup.py install
+ # or
+ $ pip install -e .
## Getting Started
RDFLib aims to be a pythonic RDF API. RDFLib's main data object is a `Graph` which is a Python collection