summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Arndt <arndtn@gmail.com>2021-03-05 15:25:34 +0100
committerGitHub <noreply@github.com>2021-03-05 15:25:34 +0100
commit16b218ba20fca55ebd2d1e1ba923a0c3f50c6c36 (patch)
tree89f99e099c22aaeec419e9a7afe33d9afb3f2f48
parente3664573b7e69ff6920e3efffd28b1db8552fa4e (diff)
parentcc0d8b4a0723fdde21e52a5b05305cffddd7a3f6 (diff)
downloadrdflib-16b218ba20fca55ebd2d1e1ba923a0c3f50c6c36.tar.gz
Merge pull request #1267 from white-gecko/feature/coverage-configuration
Feature/coverage configuration
-rw-r--r--.coveragerc36
-rw-r--r--.drone.yml9
-rw-r--r--.travis.yml3
-rw-r--r--requirements.dev.txt2
-rw-r--r--setup.cfg16
5 files changed, 26 insertions, 40 deletions
diff --git a/.coveragerc b/.coveragerc
deleted file mode 100644
index c68b1326..00000000
--- a/.coveragerc
+++ /dev/null
@@ -1,36 +0,0 @@
-# .coveragerc to control coverage.py
-[run]
-branch = True
-#source = rdflib,build/src/rdflib # specified in .travis.yml for different envs
-omit = */site-packages/*
-
-[report]
-# Regexes for lines to exclude from consideration
-exclude_lines =
- # Have to re-enable the standard pragma
- pragma: no cover
-
- # Don't complain about missing debug-only code:
- #def __repr__
- #if self\.debug
-
- # Don't complain if tests don't hit defensive assertion code:
- #raise AssertionError
- #raise NotImplementedError
-
- # Don't complain if non-runnable code isn't run:
- if 0:
- if __name__ == .__main__.:
- if __name__==.__main__.:
-
-# path mappings for the py3 environments (doesn't seem to work on coveralls yet)
-[paths]
-source =
- rdflib/
- build/src/rdflib/
-tests =
- test/
- build/src/test/
-examples =
- examples/
- build/src/examples/
diff --git a/.drone.yml b/.drone.yml
index bbaf37ee..e40f9358 100644
--- a/.drone.yml
+++ b/.drone.yml
@@ -14,10 +14,11 @@ steps:
- bash .travis.fuseki_install_optional.sh
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
- - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
- flake8 --exit-zero rdflib
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+ - coverage report
---
kind: pipeline
@@ -34,10 +35,11 @@ steps:
- bash .travis.fuseki_install_optional.sh
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
- - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
- flake8 --exit-zero rdflib
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+ - coverage report
---
kind: pipeline
@@ -54,7 +56,8 @@ steps:
- bash .travis.fuseki_install_optional.sh
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
- - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
- flake8 --exit-zero rdflib
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+ - coverage report
diff --git a/.travis.yml b/.travis.yml
index 8f8d3385..0e28b1d4 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -29,7 +29,7 @@ before_install:
install:
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
- - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
before_script:
@@ -37,6 +37,7 @@ before_script:
script:
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+ - coverage report
after_success:
- if [[ $HAS_COVERALLS ]] ; then coveralls ; fi
diff --git a/requirements.dev.txt b/requirements.dev.txt
index 059a4e9e..77fda028 100644
--- a/requirements.dev.txt
+++ b/requirements.dev.txt
@@ -1,5 +1,7 @@
sphinx
sphinxcontrib-apidoc
nose==1.3.7
+nose-timer
+coverage
flake8
doctest-ignore-unicode==0.1.2
diff --git a/setup.cfg b/setup.cfg
index cc063e11..b6cf95e7 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -11,3 +11,19 @@ exclude=rdflib.plugins.sparql.paths|rdflib.extras.external_graph_libs
ignore = W806
max-line-length = 88
exclude = host,extras,transform,rdfs,pyRdfa,sparql,results,pyMicrodata
+
+[coverage:run]
+branch = True
+#source = rdflib,build/src/rdflib # specified in .travis.yml for different envs
+omit = */site-packages/*
+
+[coverage:report]
+# Regexes for lines to exclude from consideration
+exclude_lines =
+ # Have to re-enable the standard pragma
+ pragma: no cover
+
+ # Don't complain if non-runnable code isn't run:
+ if 0:
+ if __name__ == .__main__.:
+ if __name__==.__main__.: