summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Bollweg <nick.bollweg@gmail.com>2023-03-17 16:52:11 -0500
committerGitHub <noreply@github.com>2023-03-17 22:52:11 +0100
commite3884b72f92888f6ebd251c5d748ba35c796d7ca (patch)
tree7dd8966da3a10595b77f221d632b378350a1a504
parentbea782f925991d61923b6ec5f57098e9ac19acf0 (diff)
downloadrdflib-e3884b72f92888f6ebd251c5d748ba35c796d7ca.tar.gz
build: include test in sdist (#2282)
A perhaps minor regression from earlier versions is that the sdist does not include the test folder, which makes it harder for downstreams to use a single source of truth to build and test a reliable package. This restores the test folder for sdists.
-rw-r--r--pyproject.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 8329fb6c..aa53bdac 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -25,6 +25,9 @@ readme = "README.md"
packages = [
{ include = "rdflib" },
]
+include = [
+ { path = "test", format = "sdist" },
+]
[tool.poetry.scripts]
rdfpipe = 'rdflib.tools.rdfpipe:main'