summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshley Sommer <ashleysommer@gmail.com>2021-02-05 19:49:23 +1000
committerGitHub <noreply@github.com>2021-02-05 19:49:23 +1000
commit4a302039ac0d4f9fcb6aacfeaa1bc88b241c7411 (patch)
treea2bbbe11e24b3c51ba6e827999351e5a3a718fa9
parent651fc848181df9183ed33e95e377ae5fbff9f349 (diff)
downloadrdflib-4a302039ac0d4f9fcb6aacfeaa1bc88b241c7411.tar.gz
Add a Drone config file.
Replaces #1246 Unfortunately the code duplication is required in this case. Drone doesn't have quite as sophisticated matrix runner functionality that Travis has. See here: https://docs.drone.io/pipeline/docker/examples/languages/python/ We could parametrically create the runners using a jsonnet file (as shown at the bottom of that example page) but I wanted to keep it all in the .yml file if possible.
-rw-r--r--.drone.yml60
1 files changed, 60 insertions, 0 deletions
diff --git a/.drone.yml b/.drone.yml
new file mode 100644
index 00000000..bbaf37ee
--- /dev/null
+++ b/.drone.yml
@@ -0,0 +1,60 @@
+---
+kind: pipeline
+name: python-3-6
+type: docker
+platform:
+ os: linux
+ arch: amd64
+
+steps:
+- name: test
+ image: python:3.6
+ commands:
+ - pip install -U setuptools pip
+ - bash .travis.fuseki_install_optional.sh
+ - pip install --default-timeout 60 -r requirements.txt
+ - pip install --default-timeout 60 -r requirements.dev.txt
+ - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - python setup.py install
+ - flake8 --exit-zero rdflib
+ - PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+
+---
+kind: pipeline
+name: python-3-7
+type: docker
+platform:
+ os: linux
+ arch: amd64
+
+steps:
+- name: test
+ image: python:3.7
+ commands:
+ - bash .travis.fuseki_install_optional.sh
+ - pip install --default-timeout 60 -r requirements.txt
+ - pip install --default-timeout 60 -r requirements.dev.txt
+ - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - python setup.py install
+ - flake8 --exit-zero rdflib
+ - PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
+
+---
+kind: pipeline
+name: python-3-8
+type: docker
+platform:
+ os: linux
+ arch: amd64
+
+steps:
+- name: test
+ image: python:3.8
+ commands:
+ - bash .travis.fuseki_install_optional.sh
+ - pip install --default-timeout 60 -r requirements.txt
+ - pip install --default-timeout 60 -r requirements.dev.txt
+ - pip install --default-timeout 60 coverage coveralls nose-timer && export HAS_COVERALLS=1
+ - python setup.py install
+ - flake8 --exit-zero rdflib
+ - PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib