summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Car <nicholas.car@surroundaustralia.com>2021-09-06 09:18:10 +1000
committerGitHub <noreply@github.com>2021-09-06 09:18:10 +1000
commitaa7233a3f2512c8791a5ebba3929b55af97fbfe7 (patch)
tree92e69eaef72b7ffa64763be03dced609850c6cea
parent506244c74459c264b4577e463013427cfdc50913 (diff)
downloadrdflib-aa7233a3f2512c8791a5ebba3929b55af97fbfe7.tar.gz
Revert black (#1400)
* add dateTimeStamp, fundamental & constraining facets, 7-prop data model * revert black version to that pinned in black.toml * Revert "add dateTimeStamp, fundamental & constraining facets, 7-prop data model" This reverts commit e5bcdd381b73c9ecfd436d1f8e221b27aedd5d3c.
-rw-r--r--admin/README.md3
-rw-r--r--rdflib/namespace/_XSD.py124
-rw-r--r--requirements.dev.txt2
-rw-r--r--setup.py2
4 files changed, 49 insertions, 82 deletions
diff --git a/admin/README.md b/admin/README.md
index e56c2612..67d27a2d 100644
--- a/admin/README.md
+++ b/admin/README.md
@@ -23,9 +23,8 @@ Tools to assist with RDFlib releases, like extracting all merged PRs from GitHub
* `python3 setup.py bdist_wheel sdist`
* `twine upload ./dist/*`
1. Make GitHub release
- * go to the tagged version, e.g. https://github.com/RDFLib/rdflib/releases/tag/6.0.0
+ * go to the taged version, e.g. https://github.com/RDFLib/rdflib/releases/tag/6.0.0
* edit the release' notes there (likely copy from CHANGELOG)
1. Build readthedocs docco
* `latest` and `stable` need to be built at least
* best to make sure the previous (outgoing) release has a number-pegged version, e.g. 5.0.0
-1. update the rdflib.dev website page
diff --git a/rdflib/namespace/_XSD.py b/rdflib/namespace/_XSD.py
index 80b63862..98c1618d 100644
--- a/rdflib/namespace/_XSD.py
+++ b/rdflib/namespace/_XSD.py
@@ -7,87 +7,55 @@ class XSD(DefinedNamespace):
W3C XML Schema Definition Language (XSD) 1.1 Part 2: Datatypes
Generated from: ../schemas/datatypes.xsd
- Date: 2021-09-05 20:37+10
+ Date: 2020-05-26 14:21:14.993677
"""
- _NS = Namespace("http://www.w3.org/2001/XMLSchema#")
-
- ENTITIES: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#ENTITIES
- ENTITY: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#ENTITY
- ID: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#ID
- IDREF: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#IDREF
- IDREFS: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#IDREFS
- NCName: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#NCName
- NMTOKEN: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#NMTOKEN
- NMTOKENS: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#NMTOKENS
- NOTATION: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#NOTATIONNOTATION cannot be used directly in a schema; rather a type
- Name: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#Name
- QName: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#QName
- anyURI: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#anyURI
- base64Binary: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#base64Binary
- boolean: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#boolean
- byte: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#byte
- date: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#date
- dateTime: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#dateTime
- dateTimeStamp: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#dateTimeStamp
+ ENTITIES: URIRef # see: http://www.w3.org/TR/xmlschema-2/#ENTITIES
+ ENTITY: URIRef # see: http://www.w3.org/TR/xmlschema-2/#ENTITY
+ ID: URIRef # see: http://www.w3.org/TR/xmlschema-2/#ID
+ IDREF: URIRef # see: http://www.w3.org/TR/xmlschema-2/#IDREF
+ IDREFS: URIRef # see: http://www.w3.org/TR/xmlschema-2/#IDREFS
+ NCName: URIRef # see: http://www.w3.org/TR/xmlschema-2/#NCName
+ NMTOKEN: URIRef # see: http://www.w3.org/TR/xmlschema-2/#NMTOKEN
+ NMTOKENS: URIRef # see: http://www.w3.org/TR/xmlschema-2/#NMTOKENS
+ NOTATION: URIRef # see: http://www.w3.org/TR/xmlschema-2/#NOTATIONNOTATION cannot be used directly in a schema; rather a type
+ Name: URIRef # see: http://www.w3.org/TR/xmlschema-2/#Name
+ QName: URIRef # see: http://www.w3.org/TR/xmlschema-2/#QName
+ anyURI: URIRef # see: http://www.w3.org/TR/xmlschema-2/#anyURI
+ base64Binary: URIRef # see: http://www.w3.org/TR/xmlschema-2/#base64Binary
+ boolean: URIRef # see: http://www.w3.org/TR/xmlschema-2/#boolean
+ byte: URIRef # see: http://www.w3.org/TR/xmlschema-2/#byte
+ date: URIRef # see: http://www.w3.org/TR/xmlschema-2/#date
+ dateTime: URIRef # see: http://www.w3.org/TR/xmlschema-2/#dateTime
dayTimeDuration: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#dayTimeDuration
- decimal: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#decimal
- double: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#double
- duration: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#duration
- float: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#float
- gDay: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#gDay
- gMonth: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#gMonth
- gMonthDay: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#gMonthDay
- gYear: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#gYear
- gYearMonth: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#gYearMonth
- hexBinary: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#binary
- int: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#int
- integer: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#integer
- language: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#language
- long: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#long
- negativeInteger: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#negativeInteger
- nonNegativeInteger: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#nonNegativeInteger
- nonPositiveInteger: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#nonPositiveInteger
- normalizedString: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#normalizedString
- positiveInteger: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#positiveInteger
- short: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#short
- string: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#string
- time: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#time
- token: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#token
- unsignedByte: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#unsignedByte
- unsignedInt: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#unsignedInt
- unsignedLong: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#unsignedLong
- unsignedShort: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#unsignedShort
+ decimal: URIRef # see: http://www.w3.org/TR/xmlschema-2/#decimal
+ double: URIRef # see: http://www.w3.org/TR/xmlschema-2/#double
+ duration: URIRef # see: http://www.w3.org/TR/xmlschema-2/#duration
+ float: URIRef # see: http://www.w3.org/TR/xmlschema-2/#float
+ gDay: URIRef # see: http://www.w3.org/TR/xmlschema-2/#gDay
+ gMonth: URIRef # see: http://www.w3.org/TR/xmlschema-2/#gMonth
+ gMonthDay: URIRef # see: http://www.w3.org/TR/xmlschema-2/#gMonthDay
+ gYear: URIRef # see: http://www.w3.org/TR/xmlschema-2/#gYear
+ gYearMonth: URIRef # see: http://www.w3.org/TR/xmlschema-2/#gYearMonth
+ hexBinary: URIRef # see: http://www.w3.org/TR/xmlschema-2/#binary
+ int: URIRef # see: http://www.w3.org/TR/xmlschema-2/#int
+ integer: URIRef # see: http://www.w3.org/TR/xmlschema-2/#integer
+ language: URIRef # see: http://www.w3.org/TR/xmlschema-2/#language
+ long: URIRef # see: http://www.w3.org/TR/xmlschema-2/#long
+ negativeInteger: URIRef # see: http://www.w3.org/TR/xmlschema-2/#negativeInteger
+ nonNegativeInteger: URIRef # see: http://www.w3.org/TR/xmlschema-2/#nonNegativeInteger
+ nonPositiveInteger: URIRef # see: http://www.w3.org/TR/xmlschema-2/#nonPositiveInteger
+ normalizedString: URIRef # see: http://www.w3.org/TR/xmlschema-2/#normalizedString
+ positiveInteger: URIRef # see: http://www.w3.org/TR/xmlschema-2/#positiveInteger
+ short: URIRef # see: http://www.w3.org/TR/xmlschema-2/#short
+ string: URIRef # see: http://www.w3.org/TR/xmlschema-2/#string
+ time: URIRef # see: http://www.w3.org/TR/xmlschema-2/#time
+ token: URIRef # see: http://www.w3.org/TR/xmlschema-2/#token
+ unsignedByte: URIRef # see: http://www.w3.org/TR/xmlschema-2/#unsignedByte
+ unsignedInt: URIRef # see: http://www.w3.org/TR/xmlschema-2/#unsignedInt
+ unsignedLong: URIRef # see: http://www.w3.org/TR/xmlschema-2/#unsignedLong
+ unsignedShort: URIRef # see: http://www.w3.org/TR/xmlschema-2/#unsignedShort
yearMonthDuration: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#yearMonthDuration
- # fundamental facets - https://www.w3.org/TR/xmlschema11-2/#rf-fund-facets
- ordered: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-ordered
- bounded: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-bounded
- cardinality: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-cardinality
- numeric: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-numeric
-
- # constraining facets - https://www.w3.org/TR/xmlschema11-2/#rf-facets
- length: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-length
- minLength: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-minLength
- maxLength: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-maxLength
- pattern: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-pattern
- enumeration: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-enumeration
- whiteSpace: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-whiteSpace
- maxExclusive: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-maxExclusive
- maxInclusive: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-maxInclusive
- minExclusive: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-minExclusive
- minInclusive: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-minInclusive
- totalDigits: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-totalDigits
- fractionDigits: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-fractionDigits
- Assertions: URIRef # see: https://www.w3.org/TR/xmlschema11-2/#rf-assertions
- explicitTimezone: URIRef # see: http://www.w3.org/TR/xmlschema11-2/#rf-explicitTimezone
-
- # The Seven-property Model - https://www.w3.org/TR/xmlschema11-2/#theSevenPropertyModel
- year: URIRef # see: https://www.w3.org/TR/xmlschema11-2/#vp-dt-http://www.w3.org/TR/xmlschema11-2/#rf-whiteSpace
- month: URIRef # see: https://www.w3.org/TR/xmlschema11-2/#vp-dt-month
- day: URIRef # see: https://www.w3.org/TR/xmlschema11-2/#vp-dt-day
- hour: URIRef # see: https://www.w3.org/TR/xmlschema11-2/#vp-dt-hour
- minute: URIRef # see: https://www.w3.org/TR/xmlschema11-2/#vp-dt-minute
- second: URIRef # see: https://www.w3.org/TR/xmlschema11-2/#vp-dt-second
- timezoneOffset: URIRef # see: https://www.w3.org/TR/xmlschema11-2/#vp-dt-timezone
+ _NS = Namespace("http://www.w3.org/2001/XMLSchema#")
diff --git a/requirements.dev.txt b/requirements.dev.txt
index be3f8fa3..e0b9cf7a 100644
--- a/requirements.dev.txt
+++ b/requirements.dev.txt
@@ -6,4 +6,4 @@ coverage
flake8
doctest-ignore-unicode==0.1.2
berkeleydb
-black==21.7b0
+black==21.6b0
diff --git a/setup.py b/setup.py
index a769b255..7c9e7ec3 100644
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,7 @@ kwargs["tests_require"] = [
"nose==1.3.7",
"nose-timer",
"coverage",
- "black==21.7b0",
+ "black==21.6b0",
"flake8",
"doctest-ignore-unicode==0.1.2",
]