summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorJoern Hees <gitdev@joernhees.de>2013-06-21 14:10:19 +0200
committerJoern Hees <gitdev@joernhees.de>2013-06-23 16:38:25 +0200
commitabf07edb5d67fa6a2c1d20caa8681153b1e5e39b (patch)
tree05b0db9f5a52a797b44d798522adb4dd06b46116 /.travis.yml
parent682d8161b5b0f1788b0f72a44a7dcdd37e57dad0 (diff)
downloadrdflib-abf07edb5d67fa6a2c1d20caa8681153b1e5e39b.tar.gz
coveralls ci, badge in readme. resolves #308
this squashes the several trial and error attempts to get the integration running from the coveralls-ci branch into a single commit, as that stuff is mostly rdflib unrelated.
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml10
1 files changed, 7 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 2ef4a09c..1fc1dac4 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,7 +4,6 @@ language: python
branches:
only:
- master
- - coveralls-ci
python:
- 2.5
@@ -21,6 +20,7 @@ install:
- if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then pip install --use-mirrors --default-timeout 60 -r requirements.py2.txt; pip install --use-mirrors --default-timeout 60 "html5lib";fi
- if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '3' ]]; then pip install --use-mirrors --default-timeout 60 -r requirements.py3.txt; fi
- if [[ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then pip install --upgrade "https://bitbucket.org/gjhiggins/isodate/downloads/isodate-0.4.8.tar.gz"; pip install --use-mirrors --default-timeout 60 "elementtree"; fi
+ - if [[ $TRAVIS_PYTHON_VERSION != '2.5' ]]; then pip install --use-mirrors --default-timeout 60 coverage coveralls && export HAS_COVERALLS=1; fi
- python setup.py install
before_script:
@@ -30,8 +30,12 @@ script:
# Must run the tests in build/src so python3 doesn't get confused and run
# the python2 code from the current directory instead of the installed
# 2to3 version in build/src.
- - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then nosetests; fi
- - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '3' ]]; then nosetests --where=./build/src; fi
+ - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then nosetests --with-coverage --cover-tests --cover-package=rdflib ; fi
+ - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '3' ]]; then nosetests --with-coverage --cover-tests --cover-package=build/src/rdflib --where=./build/src; fi
+
+after_success:
+ - if [[ $HAS_COVERALLS ]] ; then coveralls ; fi
+
# notifications:
# irc:
# channels: "irc.freenode.org#rdflib"