summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorGraham Higgins <gjh-github@bel-epa.com>2013-02-07 11:08:49 +0000
committerGraham Higgins <gjh-github@bel-epa.com>2013-02-07 11:08:49 +0000
commit9bae035d07d1f6601df000e2e7cd87ce539715b2 (patch)
treef0e654ff2fd5f5ae7db1f832a37a79706fdc92d7 /.travis.yml
parente878ee5134d0642e3ee439c094612d7754e99e44 (diff)
downloadrdflib-9bae035d07d1f6601df000e2e7cd87ce539715b2.tar.gz
use common .travis.yml
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml8
1 files changed, 6 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index bb7cb23c..23844f01 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,7 +4,7 @@ language: python
branches:
only:
- master
- # - rdf11
+ - rdf11
- reunif
python:
- "2.5"
@@ -16,7 +16,11 @@ python:
install:
# iodate0.4.8 is problematic with Pypy, use fixed version
- if [[ $TRAVIS_PYTHON_VERSION == '2.5' ]]; then pip install --use-mirrors "simplejson"; fi
- - pip install -r requirements.txt --use-mirrors
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.5' ] && [ $TRAVIS_BRANCH == 'reunif' ]]; then pip install --use-mirrors "ordereddict" "elementtree"; fi
+ - if [[ $TRAVIS_PYTHON_VERSION == '2.6' ] && [ $TRAVIS_BRANCH == 'reunif' ]]; then pip install --use-mirrors "ordereddict"; fi
+ - if [[ $TRAVIS_PYTHON_VERSION != '3.2' ]]; then pip install --use-mirrors -r requirements.py2.txt; fi
+ - if [[ $TRAVIS_PYTHON_VERSION == '3.2' ]]; then pip install --use-mirrors -r requirements.py3.txt; fi
+# - pip install -r requirements.txt --use-mirrors
- if [[ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then pip install --upgrade "https://bitbucket.org/gjhiggins/isodate/downloads/isodate-0.4.8.tar.gz"; fi
- python setup.py install
script: