summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorGraham Higgins <gjh-github@bel-epa.com>2013-02-09 15:08:18 +0000
committerGraham Higgins <gjh-github@bel-epa.com>2013-02-09 15:08:18 +0000
commit315de1d737d4e9246d2e3be48f8d532850932a13 (patch)
tree8a7619b11ad9b7af469d20f5f1ccfef68304f0b6 /.travis.yml
parent000e442b034bea2148593ff906aa1b3ecec214f4 (diff)
downloadrdflib-315de1d737d4e9246d2e3be48f8d532850932a13.tar.gz
travising
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml13
1 files changed, 5 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 399c6eac..040ae74b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,7 +5,6 @@ branches:
only:
- master
- rdf11
- - reunif
python:
- "2.5"
- "2.6"
@@ -17,10 +16,8 @@ python:
install:
# iodate0.4.8 is problematic with Pypy, use fixed version
- if [[ $TRAVIS_PYTHON_VERSION == '2.5' ]]; then pip install --use-mirrors "simplejson"; fi
- - if [[ $TRAVIS_PYTHON_VERSION == '2.5' && $TRAVIS_BRANCH == 'reunif' ]]; then pip install --use-mirrors "ordereddict" "elementtree"; fi
- - if [[ $TRAVIS_PYTHON_VERSION == '2.6' && $TRAVIS_BRANCH == 'reunif' ]]; then pip install --use-mirrors "ordereddict"; fi
- - if [[ $TRAVIS_PYTHON_VERSION != '3.2' ]]; then pip install --use-mirrors -r requirements.py2.txt; fi
- - if [[ $TRAVIS_PYTHON_VERSION == '3.2' ]]; then pip install --use-mirrors -r requirements.py3.txt; fi
+ - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then pip install --use-mirrors -r requirements.py2.txt; fi
+ - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '3' ]]; then pip install --use-mirrors -r requirements.py3.txt; fi
# - pip install -r requirements.txt --use-mirrors
- if [[ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then pip install --upgrade "https://bitbucket.org/gjhiggins/isodate/downloads/isodate-0.4.8.tar.gz"; fi
- python setup.py install
@@ -28,10 +25,10 @@ script:
# Must run the tests in build/src so python3 doesn't get confused and run
# the python2 code from the current directory instead of the installed
# 2to3 version in build/src.
- - if [[ $TRAVIS_PYTHON_VERSION != '3.2' ]]; then nosetests; fi
- - if [[ $TRAVIS_PYTHON_VERSION == '3.2' ]]; then nosetests --where=./build/src; fi
+ - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '2' ]]; then nosetests; fi
+ - if [[ ${TRAVIS_PYTHON_VERSION%%.*} == '3' ]]; then nosetests --where=./build/src; fi
before_script:
- - "flake8 --exit-zero rdflib"
+ - "flake8 --exclude=pyRdfa,extras,host,transform,rdfs,sparql,results,pyMicrodata --exit-zero rdflib"
notifications:
irc:
channels: "irc.freenode.org#rdflib"