summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStan Hu <stanhu@aclimalabs.com>2014-07-04 17:36:00 -0700
committerStan Hu <stanhu@aclimalabs.com>2014-07-04 17:36:00 -0700
commit4da40371768df6dc856ea9cf0fafc121d98c3b8a (patch)
treea7dc891d9793eebb3e30111a94f13233b786676c /setup.py
parent133fcdb74869bb270f75642889b17b0752bf0b6e (diff)
downloadraven-4da40371768df6dc856ea9cf0fafc121d98c3b8a.tar.gz
Set the test_suite variable to avoid TypeError in setuptools
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c3ebaaa..739ad4b 100755
--- a/setup.py
+++ b/setup.py
@@ -84,9 +84,12 @@ tests_require = [
class PyTest(TestCommand):
+ def initialize_options(self):
+ TestCommand.initialize_options(self)
+ self.test_suite = 'tests'
+
def finalize_options(self):
TestCommand.finalize_options(self)
- self.test_suite = True
def run_tests(self):
#import here, cause outside the eggs aren't loaded