summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorXavier Ordoquy <xordoquy@linovia.com>2015-02-13 01:56:04 +0100
committerXavier Ordoquy <xordoquy@linovia.com>2015-02-13 01:56:04 +0100
commit4b5afd644896f83f4874e8d90daf4fe26285b804 (patch)
tree9af12136c6c53c34686066df429e9f34b9cef7dc /setup.py
parent1e893c9feadddc2a1513e1a9ea801ca57ebd8893 (diff)
parent4da40371768df6dc856ea9cf0fafc121d98c3b8a (diff)
downloadraven-4b5afd644896f83f4874e8d90daf4fe26285b804.tar.gz
Merge pull request #471 from stanhu/fix-pytest
Set the test_suite variable to avoid TypeError in setuptools
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 19e9a25..13f5cae 100755
--- a/setup.py
+++ b/setup.py
@@ -82,9 +82,12 @@ tests_require = [
class PyTest(TestCommand):
+ def initialize_options(self):
+ TestCommand.initialize_options(self)
+ self.test_suite = 'tests'
+
def finalize_options(self):
TestCommand.finalize_options(self)
- self.test_suite = True
def run_tests(self):
# import here, cause outside the eggs aren't loaded