summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Cramer <dcramer@gmail.com>2012-12-26 13:48:26 -0800
committerDavid Cramer <dcramer@gmail.com>2012-12-26 13:48:26 -0800
commitce4d6ef638c2e2795596a175b72203f213e5384b (patch)
tree7444937fe86394c28842c79548460bd667b9c22c
parent8ba053a63140cabc009371fdc3a5984637ab2e16 (diff)
downloadraven-ce4d6ef638c2e2795596a175b72203f213e5384b.tar.gz
Improve contributing docs to reflect current shortcuts
-rw-r--r--docs/contributing/index.rst21
1 files changed, 3 insertions, 18 deletions
diff --git a/docs/contributing/index.rst b/docs/contributing/index.rst
index 39ef43b..18cd181 100644
--- a/docs/contributing/index.rst
+++ b/docs/contributing/index.rst
@@ -19,7 +19,7 @@ any base dependancies.
virtualenv ~/.virtualenvs/raven
source ~/.virtualenvs/raven/bin/activate
- python setup.py develop
+ make
Running the Test Suite
----------------------
@@ -30,22 +30,7 @@ any dependancies you're missing automatically.
::
- python setup.py test
-
-If you've already installed the dependancies, or don't care about certain tests which will
-be skipped without them, you can also run tests in a more verbose way.
-
-::
-
- python runtests.py
-
-The ``runtests.py`` command has several options, and if you're familiar w/ Django you should feel
-right at home.
-
-::
-
- # Stop immediately on a failure
- python runtests.py --failfast
+ make test
Contributing Back Code
@@ -53,4 +38,4 @@ Contributing Back Code
Ideally all patches should be sent as a pull request on GitHub, and include tests. If you're fixing a bug or making a large change the patch **must** include test coverage.
-You can see a list of open pull requests (pending changes) by visiting https://github.com/getsentry/raven-python/pulls \ No newline at end of file
+You can see a list of open pull requests (pending changes) by visiting https://github.com/getsentry/raven-python/pulls