summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshley Camba Garrido <ashwoods@gmail.com>2017-08-09 17:08:15 +0200
committerAshley Camba Garrido <ashwoods@gmail.com>2017-08-09 17:12:00 +0200
commitea260cef86a619bcb8e765a2567feef5163024ad (patch)
treefa0a4ad1f40be957cb1c89d4cf542e04778e359a
parent911f426a45e987f214d75ddd1a1177d0b70b11c0 (diff)
downloadraven-ea260cef86a619bcb8e765a2567feef5163024ad.tar.gz
Update setup.py and setup.cfg for tox-travis-refactor
-rw-r--r--setup.cfg8
-rwxr-xr-xsetup.py12
2 files changed, 15 insertions, 5 deletions
diff --git a/setup.cfg b/setup.cfg
index 1557c85..79fcf75 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -2,11 +2,15 @@
python_files=test*.py
addopts=--tb=native -p no:doctest
norecursedirs=raven build bin dist docs htmlcov hooks node_modules .* {args}
+DJANGO_SETTINGS_MODULE = tests.contrib.django.settings
+python_paths = tests
+flake8-ignore =
+ tests/ ALL
[flake8]
-ignore = F999,E501,E128,E124,E402,W503,E731,F841
+ignore = F999,E501,E128,E124,E402,W503,E731,F841,D100,D101,D102,D103,D104,D105,D200,D201,D205,D400,D401,D402,D403,I100,I101
max-line-length = 100
-exclude = .tox,.git,docs
+exclude = .tox,.git,docs,tests
[bdist_wheel]
universal = 1
diff --git a/setup.py b/setup.py
index 7e91788..c7f63a0 100755
--- a/setup.py
+++ b/setup.py
@@ -67,14 +67,20 @@ tests_require = [
'bottle',
'celery>=2.5',
'exam>=0.5.2',
- 'flake8>=2.6,<2.7',
+ 'flake8==3.4.1',
'logbook',
'mock',
'nose',
'pycodestyle',
'pytz',
- 'pytest>=3.0.0,<3.1.0',
- 'pytest-timeout==0.4',
+ 'pytest>=3.1.0,<3.2.0',
+ 'pytest-timeout==1.2.0',
+ 'pytest-xdist==1.18.2',
+ 'pytest-pythonpath',
+ 'pytest-sugar==0.8',
+ 'pytest-assume',
+ 'pytest-cov',
+ 'pytest-flake8',
'requests',
'tornado>=4.1',
'webob',