summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2011-12-15 22:13:30 +0000
committerAlan Conway <aconway@apache.org>2011-12-15 22:13:30 +0000
commit643ccb0d5f391be211fd84a0d1fab193c3a228c3 (patch)
treec8ee80c2719a04568f491239b23bd310074050bb
parent0079ea838250b4b307f6c6c130cc107b4a9f74fa (diff)
downloadqpid-python-643ccb0d5f391be211fd84a0d1fab193c3a228c3.tar.gz
QPID-3603: Disable federation cluster tests on qpid-3603 branch.
These tests are known to be broken by the new HA work. We will need to fix them and re-enable at some point. git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/qpid-3603@1214971 13f79535-47bb-0310-9956-ffa450edef68
-rwxr-xr-xqpid/cpp/src/tests/run_federation_sys_tests17
1 files changed, 10 insertions, 7 deletions
diff --git a/qpid/cpp/src/tests/run_federation_sys_tests b/qpid/cpp/src/tests/run_federation_sys_tests
index f5f772d72e..d9676d56a0 100755
--- a/qpid/cpp/src/tests/run_federation_sys_tests
+++ b/qpid/cpp/src/tests/run_federation_sys_tests
@@ -25,13 +25,16 @@ source ./test_env.sh
MODULENAME=federation_sys
-# Test for clustering
-ps -u root | grep 'aisexec\|corosync' > /dev/null
-if (( $? == 0 )); then
- CLUSTERING_ENABLED=1
-else
- echo "WARNING: No clustering detected; tests using it will be ignored."
-fi
+# FIXME aconway 2011-12-15: Disable cluster-related tests on the qpid-3603
+# branch. See comment in cluster.mk for more details.
+#
+# # Test for clustering
+# ps -u root | grep 'aisexec\|corosync' > /dev/null
+# if (( $? == 0 )); then
+# CLUSTERING_ENABLED=1
+# else
+# echo "WARNING: No clustering detected; tests using it will be ignored."
+# fi
# Test for long test
if [[ "$1" == "LONG_TEST" ]]; then