summaryrefslogtreecommitdiff
path: root/format.sh
diff options
context:
space:
mode:
Diffstat (limited to 'format.sh')
-rwxr-xr-xformat.sh13
1 files changed, 13 insertions, 0 deletions
diff --git a/format.sh b/format.sh
new file mode 100755
index 0000000..cd6122d
--- /dev/null
+++ b/format.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+# Ignoring autogenerated files
+# -- Migration directories
+# Ignoring error codes
+# -- E128 continuation line under-indented for visual indent
+# -- E261 at least two spaces before inline comment
+# -- E225 missing whitespace around operator
+# -- E501 line too long
+# Ignoring warning codes
+# -- W605 invalid escape sequence '\d'
+
+pycodestyle --ignore=E128,E261,E225,E501,W605 slugify test.py setup.py