summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Socol <me@jamessocol.com>2014-01-03 02:13:59 -0500
committerJames Socol <me@jamessocol.com>2014-01-03 02:13:59 -0500
commit22b53928d86b5fd5bffb76271f409ec75e6d55fb (patch)
treeeec0f07ebebe43ec29a937ddb9b67fbc5fe7357d
parent59e3e2e64a3009697502c6064da997268419921a (diff)
downloadpystatsd-22b53928d86b5fd5bffb76271f409ec75e6d55fb.tar.gz
Do versioning simpler.v2.1
-rw-r--r--setup.py16
-rw-r--r--statsd/__init__.py3
-rw-r--r--statsd/_version.py2
3 files changed, 3 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 01df43e..0bb0cef 100644
--- a/setup.py
+++ b/setup.py
@@ -3,23 +3,9 @@ import re
from setuptools import find_packages, setup
-VERSIONFILE = os.path.join('statsd', '_version.py')
-VSRE = r'^__version__ = [\'"]([^\'"]*)[\'"]'
-
-
-def get_version():
- verstrline = open(VERSIONFILE, "rt").read()
- mo = re.search(VSRE, verstrline, re.M)
- if mo:
- return mo.group(1)
- else:
- raise RuntimeError(
- "Unable to find version string in %s." % VERSIONFILE)
-
-
setup(
name='statsd',
- version=get_version(),
+ version='2.1',
description='A simple statsd client.',
long_description=open('README.rst').read(),
author='James Socol',
diff --git a/statsd/__init__.py b/statsd/__init__.py
index 4aa254c..440d9bf 100644
--- a/statsd/__init__.py
+++ b/statsd/__init__.py
@@ -16,9 +16,10 @@ except ImportError:
settings = None
from .client import StatsClient
-from ._version import __version__, VERSION # noqa
+VERSION = (2, 1, 0)
+__version__ = '.'.join(map(str, VERSION))
__all__ = ['StatsClient', 'statsd']
statsd = None
diff --git a/statsd/_version.py b/statsd/_version.py
deleted file mode 100644
index e2baefa..0000000
--- a/statsd/_version.py
+++ /dev/null
@@ -1,2 +0,0 @@
-VERSION = (2, 1, 0)
-__version__ = '.'.join(map(str, VERSION))