summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2012-01-05 17:07:40 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2012-01-05 17:07:40 +0000
commita5ffe7ceeca6a1f4c73d2963fc3e34fe44a2348c (patch)
tree758d51828e3708a8f90e02274c8a28e0c6a5ae40
parent8b8bb7a288a82e7eb44be97286e5057a49df4b28 (diff)
downloadpysendfile-a5ffe7ceeca6a1f4c73d2963fc3e34fe44a2348c.tar.gz
update setup.py and README
-rw-r--r--README45
-rw-r--r--setup.py13
2 files changed, 30 insertions, 28 deletions
diff --git a/README b/README
index 5e2384c..5872d01 100644
--- a/README
+++ b/README
@@ -1,14 +1,13 @@
-=================================
- About
-=================================
+=====
+About
+=====
A python interface to sendfile(2) system call:
http://code.google.com/p/py-sendfile/
-
-=================================
- Install
-=================================
+=======
+Install
+=======
$ sudo setup.py install
@@ -16,23 +15,22 @@ $ sudo setup.py install
$ easy_install py-sendfile
+===================
+Supported platforms
+===================
-=================================
- Supported platforms
-=================================
-
-Linux
-OSX
-FreeBSD
-Dragon Fly BSD
-SunOS
-AIX (non properly tested)
+* Linux
+* OSX
+* FreeBSD
+* Dragon Fly BSD
+* SunOS
+* AIX (non properly tested)
Python versions from 2.5 to 3.3 by using a single code base.
-=================================
- Example usage
-=================================
+=============
+Example usage
+=============
import socket
import errno
@@ -55,10 +53,9 @@ while 1:
break # done
offset += sent
-
-=================================
- Authors
-=================================
+=======
+Authors
+=======
py-sendfile was originally written by Ben Woolley including Linux and FreeBSD
support.
diff --git a/setup.py b/setup.py
index 7734d3a..66feeba 100644
--- a/setup.py
+++ b/setup.py
@@ -16,10 +16,15 @@ else:
libraries = []
def main():
- setup(name = 'py-sendfile',
- version = '2.0.0',
- description = 'A Python interface to sendfile(2)',
- url = 'http://code.google.com/p/py-sendfile/',
+ setup(name='py-sendfile',
+ version='2.0.0',
+ description='A Python interface to sendfile(2)',
+ url='http://code.google.com/p/py-sendfile/',
+ author='Giampaolo Rodola',
+ author_email='g.rodola@gmail.com',
+ license='License :: OSI Approved :: MIT License',
+ long_description=open('README', 'r').read(),
+ keywords=['sendfile', 'ftp'],
classifiers = [
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',