summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2011-04-21 18:06:14 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2011-04-21 18:06:14 +0000
commit4058b01d41deba4ac645690993ed350c5e8885a8 (patch)
treeb08ae1629f9abb7b337d488627aeb20915ab85a7
parent81112baa4fa190f6bb5bd5b8434b876412c3a894 (diff)
downloadpysendfile-4058b01d41deba4ac645690993ed350c5e8885a8.tar.gz
remove flags argument on linux
-rw-r--r--sendfilemodule.c9
-rw-r--r--setup.py1
2 files changed, 5 insertions, 5 deletions
diff --git a/sendfilemodule.c b/sendfilemodule.c
index 1a74b78..4e347cc 100644
--- a/sendfilemodule.c
+++ b/sendfilemodule.c
@@ -247,7 +247,6 @@ method_sendfile(PyObject *self, PyObject *args, PyObject *kwdict)
size_t tail_len = 0;
int orig_cork = 1;
int orig_cork_len = sizeof(int);
- int flags;
int ret;
ssize_t sent_h = 0;
ssize_t sent_f = 0;
@@ -255,13 +254,13 @@ method_sendfile(PyObject *self, PyObject *args, PyObject *kwdict)
PyObject *offobj;
static char *keywords[] = {"out", "in", "offset", "nbytes", "header",
- "trailer", "flags", NULL};
+ "trailer", NULL};
if (!PyArg_ParseTupleAndKeywords(args, kwdict,
- "iiOI|s#s#i:sendfile",
+ "iiOI|s#s#:sendfile",
keywords, &out_fd, &in_fd, &offobj,
&nbytes, &head, &head_len, &tail,
- &tail_len, &flags)) {
+ &tail_len)) {
return NULL;
}
@@ -397,7 +396,7 @@ SendfileMethods[] =
"On Solaris, out may be the file descriptor of a regular file or the file "
"descriptor of a socket. On all other platforms, out must be the file "
"descriptor of an open socket.\n"
-"flags argument is only supported on FreeBSD."
+"flags argument is only supported on FreeBSD (see man sendfile)."
},
{NULL, NULL, 0, NULL} /* Sentinel */
};
diff --git a/setup.py b/setup.py
index 311c148..491f961 100644
--- a/setup.py
+++ b/setup.py
@@ -20,6 +20,7 @@ def main():
'Operating System :: POSIX :: Linux',
'Operating System :: MacOS :: MacOS X',
'Operating System :: POSIX :: BSD :: FreeBSD',
+ 'Operating System :: POSIX :: SunOS/Solaris',
'Operating System :: POSIX :: AIX',
'Programming Language :: C',
'Programming Language :: Python :: 2.4',