summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoland Hedberg <roland.hedberg@adm.umu.se>2014-12-10 14:42:27 +0100
committerRoland Hedberg <roland.hedberg@adm.umu.se>2014-12-10 14:42:27 +0100
commitd89992cdc2173929b6abcc0c9075ffbd4aa01eb2 (patch)
tree563124fef19bf5eef396625c14397e26da75a1af
parentbd95adf37da42c8da650ffe1da806d2d69093a37 (diff)
downloadpysaml2-d89992cdc2173929b6abcc0c9075ffbd4aa01eb2.tar.gz
Fixed file path problem if you run 'setup.py test'
-rw-r--r--tests/test_41_response.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/tests/test_41_response.py b/tests/test_41_response.py
index 78e69174..fbad7304 100644
--- a/tests/test_41_response.py
+++ b/tests/test_41_response.py
@@ -2,8 +2,6 @@
# -*- coding: utf-8 -*-
from contextlib import closing
-from saml2.attribute_converter import to_local
-from saml2.samlp import response_from_string
from saml2 import config
from saml2.authn_context import INTERNETPROTOCOLPASSWORD
@@ -115,7 +113,7 @@ class TestResponse:
assert False
def test_other_response(self):
- xml_response = open("attribute_response.xml").read()
+ xml_response = open(full_path("attribute_response.xml")).read()
resp = response_factory(
xml_response, self.conf,
return_addrs=['https://myreviewroom.com/saml2/acs/'],