summaryrefslogtreecommitdiff
path: root/trunk/src/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/src/setup.py')
-rw-r--r--trunk/src/setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/trunk/src/setup.py b/trunk/src/setup.py
new file mode 100644
index 0000000..82061c6
--- /dev/null
+++ b/trunk/src/setup.py
@@ -0,0 +1,37 @@
+#!/usr/bin/env python
+
+"""Setup script for the pyparsing module distribution."""
+from setuptools import setup
+
+import sys
+import os
+
+from pyparsing import __version__ as pyparsing_version
+
+modules = ["pyparsing",]
+
+setup(# Distribution meta-data
+ name = "pyparsing",
+ version = pyparsing_version,
+ description = "Python parsing module",
+ author = "Paul McGuire",
+ author_email = "ptmcg@users.sourceforge.net",
+ url = "http://pyparsing.wikispaces.com/",
+ download_url = "http://sourceforge.net/project/showfiles.php?group_id=97203",
+ license = "MIT License",
+ py_modules = modules,
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Information Technology',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ ]
+ )