summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in1
-rw-r--r--docs-requirements.txt2
-rw-r--r--mypy-requirements.txt2
-rw-r--r--pymemcache/py.typed0
-rw-r--r--test-requirements.txt2
5 files changed, 4 insertions, 3 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 6e9e934..ddb59d2 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,5 +1,6 @@
include README.* ChangeLog.* setup.py setup.cfg LICENSE.txt
include *-requirements.txt tox.ini
+include pymemcache/py.typed
recursive-include pymemcache *.py
recursive-include pymemcache/test *.crt
recursive-include pymemcache/test *.key
diff --git a/docs-requirements.txt b/docs-requirements.txt
index 85f852f..ec3b583 100644
--- a/docs-requirements.txt
+++ b/docs-requirements.txt
@@ -1,4 +1,4 @@
-sphinx==5.1.1
+sphinx==5.2.1
sphinx_rtd_theme==1.0.0
sphinxcontrib-apidoc==0.3.0
sphinxcontrib-napoleon==0.7
diff --git a/mypy-requirements.txt b/mypy-requirements.txt
index 6107e5a..568b53e 100644
--- a/mypy-requirements.txt
+++ b/mypy-requirements.txt
@@ -1,2 +1,2 @@
-r test-requirements.txt
-mypy==0.971
+mypy==0.981
diff --git a/pymemcache/py.typed b/pymemcache/py.typed
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/pymemcache/py.typed
diff --git a/test-requirements.txt b/test-requirements.txt
index cb78e37..7d9fc54 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,4 +1,4 @@
-Faker==14.2.0
+Faker==15.0.0
pytest==7.1.1
pytest-cov==3.0.0
gevent==21.12.0; "PyPy" not in platform_python_implementation