summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorJon Parise <jon@pinterest.com>2019-01-28 07:38:11 -0800
committerJon Parise <jon@pinterest.com>2019-01-28 07:43:22 -0800
commit3d820b2f9c85210fd810fe8c8548265621867f69 (patch)
tree9b625f78a7327f18cdaa5e649849be2922add7d2 /setup.cfg
parentef2cf23e898124a7f336dc4bcb87c6a9c50f27c9 (diff)
downloadpymemcache-3d820b2f9c85210fd810fe8c8548265621867f69.tar.gz
Parse version directly from pymemcache/__init__.py
We can no longer import the __version__ attribute because there is no an implicit runtime dependency on six (as of #197), and we can't guarantee that six is installed until *after* setup.py is parsed and run. Instead, parse the `__version__ = 'x.y.z'` string from __init__.py to extract the version. Fixes #214
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.cfg b/setup.cfg
index 09b7379..ebab45f 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,8 +1,3 @@
-[bumpversion]
-current_version = 2.0.0
-commit = False
-tag = True
-
[bdist_wheel]
universal = true
@@ -27,6 +22,3 @@ markers =
show-source = True
max-line-length = 80
exclude = .tox/*,.venv/*,docs/*
-
-[bumpversion:file:pymemcache/__init__.py]
-