summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Parise <jon@pinterest.com>2021-07-01 09:50:43 -0700
committerGitHub <noreply@github.com>2021-07-01 09:50:43 -0700
commitb96b911eb3de7937e2e96cc144ea5226c32d0599 (patch)
treef6e0d863a6de3e86e5c3fe0ffec218405d51f730
parent5e51465761e3f6b2b8abff6771ebd4a23d4052b3 (diff)
downloadpymemcache-b96b911eb3de7937e2e96cc144ea5226c32d0599.tar.gz
Remove codespell and flake8 complexity check (#335)
I think the value provided by codespell is low and not worth the CPU cycles to run it on ever change. Also, the flake8 complexity check isn't particularly helpful (in my opinion).
-rw-r--r--.github/workflows/ci.yml5
1 files changed, 2 insertions, 3 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 88ed440..16c5a5e 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -28,9 +28,8 @@ jobs:
- name: Lint
if: matrix.python-version == '2.7' || matrix.python-version == '3.9'
run: |
- pip install codespell flake8
- codespell . --skip=./.*,./pymemcache/test/certs --quiet-level=2
- flake8 --max-complexity=18 .
+ pip install flake8
+ flake8
python setup.py check --restructuredtext
- name: Disable IPv6 localhost
run: |