summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Parise <jon@pinterest.com>2020-08-21 15:30:42 -0700
committerGitHub <noreply@github.com>2020-08-21 15:30:42 -0700
commit969a124f1cd868ba4a76c459381229fbcae1fdd8 (patch)
treeee1762d185b0d86b7c0708cf2abf826b6ce51667
parent9ba2e98b2aec6ff2dd6d7b9178c5cabb0c9d9d9f (diff)
parent0cd778ac07696000d7090dde4c6982c27d1fc332 (diff)
downloadpymemcache-969a124f1cd868ba4a76c459381229fbcae1fdd8.tar.gz
Merge pull request #294 from cclauss/patch-1
-rw-r--r--.github/workflows/ci.yml9
-rw-r--r--pymemcache/client/base.py4
-rw-r--r--pymemcache/fallback.py2
3 files changed, 8 insertions, 7 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index da57fe6..e3bb97d 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -16,9 +16,9 @@ jobs:
python-version: [2.7, 3.5, 3.6, 3.7, 3.8, pypy2, pypy3]
steps:
- - uses: actions/checkout@v1
+ - uses: actions/checkout@v2
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v1
+ uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python-version }}
- name: Install dependencies
@@ -28,8 +28,9 @@ jobs:
- name: Lint
if: matrix.python-version == '2.7' || matrix.python-version == '3.8'
run: |
- pip install flake8
- flake8 pymemcache/
+ pip install codespell flake8
+ codespell . --skip=./.*,./pymemcache/test/certs --quiet-level=2
+ flake8 --max-complexity=18 .
python setup.py check --restructuredtext
- name: Tests
run: |
diff --git a/pymemcache/client/base.py b/pymemcache/client/base.py
index 55bfb55..1bf006f 100644
--- a/pymemcache/client/base.py
+++ b/pymemcache/client/base.py
@@ -832,7 +832,7 @@ class Client(object):
"""
This function is abstracted from _fetch_cmd to support different ways
of value extraction. In order to use this feature, _extract_value needs
- to be overriden in the subclass.
+ to be overridden in the subclass.
"""
if expect_cas:
_, key, flags, size, cas = line.split()
@@ -1001,7 +1001,7 @@ class PooledClient(object):
triggers a runtime error), by default this is 2147483648L
when not provided (or none).
lock_generator: a callback/type that takes no arguments that will
- be called to create a lock or sempahore that can
+ be called to create a lock or semaphore that can
protect the pool from concurrent access (for example a
eventlet lock or semaphore could be used instead)
diff --git a/pymemcache/fallback.py b/pymemcache/fallback.py
index d70d83c..b7e9dd8 100644
--- a/pymemcache/fallback.py
+++ b/pymemcache/fallback.py
@@ -16,7 +16,7 @@
A client for falling back to older memcached servers when performing reads.
It is sometimes necessary to deploy memcached on new servers, or with a
-different configuration. In theses cases, it is undesirable to start up an
+different configuration. In these cases, it is undesirable to start up an
empty memcached server and point traffic to it, since the cache will be cold,
and the backing store will have a large increase in traffic.