summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Parise <jon@pinterest.com>2021-02-04 14:24:34 -0800
committerJon Parise <jon@indelible.org>2021-02-04 15:28:45 -0800
commitea68ad178110bd72e5e15a44f1973e76b321b497 (patch)
treea687f46450b078b66fb7b56fb6b24e5e9fe02807
parentaae4fe1bda9755f006a33b88f1589f29507996fc (diff)
downloadpymemcache-ea68ad178110bd72e5e15a44f1973e76b321b497.tar.gz
Disable IPv6 localhost resolution for CI
GitHub Actions appears to be busted with regard to IPv6-based localhost resolution between containers. This prevents us from successfully connecting to our memcached service containers. We can't resolve this by using `--server` (and `--tls-server`) to explicitly specify 127.0.0.1 to force IPv4, but that unfortunately breaks TLS certification verification because that expects 'localhost'. We should come up with a better solution for this, but for the short term, this unblocks the failing CI builds.
-rw-r--r--.github/workflows/ci.yml3
1 files changed, 3 insertions, 0 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index e3445c6..88ed440 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -32,6 +32,9 @@ jobs:
codespell . --skip=./.*,./pymemcache/test/certs --quiet-level=2
flake8 --max-complexity=18 .
python setup.py check --restructuredtext
+ - name: Disable IPv6 localhost
+ run: |
+ sudo sed -i '/::1/d' /etc/hosts
- name: Tests
run: |
pip install -r test-requirements.txt