summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Charriere <nicholascharriere@gmail.com>2017-05-05 12:15:57 -0700
committerGitHub <noreply@github.com>2017-05-05 12:15:57 -0700
commit4e4cc98433573cc06f05bad4fd46c4985831d19c (patch)
treea958ba3b26b37c174c773818ba4bfdd341c15297
parent61d002f2c65b36956052ae1e6b656b1fd2bf7d38 (diff)
parent98426e831a905cda9c023bd9cbfb8cc00e7578fb (diff)
downloadpymemcache-4e4cc98433573cc06f05bad4fd46c4985831d19c.tar.gz
Merge pull request #155 from jparise/flake8
Exclude well-known non-code paths from flake8
-rw-r--r--setup.cfg1
-rw-r--r--setup.py2
2 files changed, 2 insertions, 1 deletions
diff --git a/setup.cfg b/setup.cfg
index 685c009..a837e93 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -23,6 +23,7 @@ markers =
[flake8]
show-source = True
max-line-length = 80
+exclude = .tox/*,.venv/*,docs/*
[bumpversion:file:pymemcache/__init__.py]
diff --git a/setup.py b/setup.py
index 003cc6f..cfa4cdd 100644
--- a/setup.py
+++ b/setup.py
@@ -8,10 +8,10 @@ from pymemcache import __version__
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
readme = read('README.rst')
changelog = read('ChangeLog.rst')
-
setup(
name='pymemcache',
version=__version__,