summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2009-11-23 15:15:26 +0100
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2009-11-23 15:15:26 +0100
commit43e8f817074a0e2e865f4a061ba3956313ebe8e5 (patch)
tree75b8e46b8ecb0eda33e42eb5ad13167119990f7b /doc
parent2269b04a72bab0e1d0a5e290a4facf5636509281 (diff)
downloadpylint-43e8f817074a0e2e865f4a061ba3956313ebe8e5.tar.gz
include Dotan Barak spell fixes patch
Diffstat (limited to 'doc')
-rw-r--r--doc/beginner_pylint_tutorial.txt6
-rw-r--r--doc/features.txt54
-rw-r--r--doc/manual.txt24
-rw-r--r--doc/quickstart.txt6
4 files changed, 45 insertions, 45 deletions
diff --git a/doc/beginner_pylint_tutorial.txt b/doc/beginner_pylint_tutorial.txt
index 20875d5..589de97 100644
--- a/doc/beginner_pylint_tutorial.txt
+++ b/doc/beginner_pylint_tutorial.txt
@@ -76,7 +76,7 @@ Pylint is going to 'pick on': ::
* (R) refactor, for bad code smell
* (W) warning, for python specific problems
* (E) error, for much probably bugs in the code
- * (F) fatal, if an error occured which prevented pylint from doing
+ * (F) fatal, if an error occurred which prevented pylint from doing
further processing.
When Pylint is first run on a fresh piece of code, a common complaint is that it
@@ -211,7 +211,7 @@ If we run this: ::
--------
+-----------+-----------+
- |message id |occurences |
+ |message id |occurrences |
+===========+===========+
|C0103 |5 |
+-----------+-----------+
@@ -301,7 +301,7 @@ a docstring to line 2, put spaces around the = sign on line 16 and use the
Here's the updated code: ::
1 #!/usr/bin/env python
- 2 """This script prompts a user to enter a messsage to encode or decode
+ 2 """This script prompts a user to enter a message to encode or decode
3 using a classic Caeser shift substitution (3 letter shift)"""
4
5 import string
diff --git a/doc/features.txt b/doc/features.txt
index e98f55c..4171c4f 100644
--- a/doc/features.txt
+++ b/doc/features.txt
@@ -79,13 +79,13 @@ Reports options
command line instead of printing them on stdout. Reports (if any) will be
written in a file name "pylint_global.[txt|html]".
:reports:
- Tells wether to display a full report or only the messages
+ Tells whether to display a full report or only the messages
Default: ``yes``
:evaluation:
Python expression which should return a note less than 10 (10 is the highest
note). You have access to the variables errors warning, statement which
- respectivly contain the number of errors / warnings messages and the total
+ respectively contain the number of errors / warnings messages and the total
number of statements analyzed. This is used by the global evaluation report
(R0004).
@@ -119,16 +119,16 @@ Main messages
:I0013: *Ignoring entire file*
Used to inform that the file will not be checked
:F0001:
- Used when an error occured preventing the analysis of a module (unable to find
+ Used when an error occurred preventing the analysis of a module (unable to find
it for instance).
:F0002: *%s: %s*
- Used when an unexpected error occured while building the ASTNG representation.
+ Used when an unexpected error occurred while building the ASTNG representation.
This is usually accompanied by a traceback. Please report such errors !
:F0003: *ignored builtin module %s*
Used to indicate that the user asked to analyze a builtin module which has
been skipped.
-:F0004: *unexpected infered value %s*
- Used to indicate that some value of an unexpected type has been infered.
+:F0004: *unexpected inferred value %s*
+ Used to indicate that some value of an unexpected type has been inferred.
Main reports
~~~~~~~~~~~~
@@ -144,12 +144,12 @@ checks for
* unused variables / imports
* undefined variables
* redefinition of variable from builtins or from an outer scope
-* use of variable before assigment
+* use of variable before assignment
Options
~~~~~~~
:init-import:
- Tells wether we should check for unused import in __init__ files.
+ Tells whether we should check for unused import in __init__ files.
:dummy-variables-rgx:
A regular expression matching names used for dummy variables (i.e. not used).
@@ -169,9 +169,9 @@ Messages
:W0601: *Global variable %r undefined at the module level*
Used when a variable is defined through the "global" statement but the
variable is not defined in the module scope.
-:W0602: *Using global for %r but no assigment is done*
+:W0602: *Using global for %r but no assignment is done*
Used when a variable is defined through the "global" statement but no
- assigment to this variable is done.
+ assignment to this variable is done.
:W0603: *Using the global statement*
Used when you use the "global" statement to update a global variable. PyLint
just try to discourage this usage. That doesn't mean you can not use it !
@@ -201,7 +201,7 @@ Basic checker
checks for :
* doc strings
* modules / classes / functions / methods / arguments / variables name
-* number of arguments, local variables, branchs, returns and statements in
+* number of arguments, local variables, branches, returns and statements in
functions, methods
* required module attributes
* dangerous default values as arguments
@@ -299,7 +299,7 @@ Messages
disable it if you're using those strings as documentation, instead of
comments.
:W0106: *Unnecessary semicolon*
- Used when a statement is endend by a semi-colon (";"), which isn't necessary
+ Used when a statement is ended by a semi-colon (";"), which isn't necessary
(that's python, not C ;).
:W0107: *Unnecessary pass statement*
Used when a "pass" statement that can be avoided is encountered.)
@@ -340,13 +340,13 @@ try to find bugs in the code using type inference
Options
~~~~~~~
:ignore-mixin-members:
- Tells wether missing members accessed in mixin class should be ignored. A
+ Tells whether missing members accessed in mixin class should be ignored. A
mixin class is detected if its name ends with "mixin" (case insensitive).
Default: ``yes``
:ignored-classes:
List of classes names for which member attributes should not be checked
- (useful for classes with attributes dynamicaly set).
+ (useful for classes with attributes dynamically set).
Default: ``SQLObject``
:zope:
@@ -361,17 +361,17 @@ Options
Messages
~~~~~~~~
:E1101: *%s %r has no %r member*
- Used when a variable is accessed for an unexistant member.
+ Used when a variable is accessed for an unexistent member.
:E1102: *%s is not callable*
- Used when an object being called has been infered to a non callable object
+ Used when an object being called has been inferred to a non callable object
:E1103: *%s %r has no %r member (but some types could not be inferred)*
- Used when a variable is accessed for an unexistant member, but astng was not
+ Used when a variable is accessed for an unexistent member, but astng was not
able to interpret all possible types of this variable.
:E1111: *Assigning to function call which doesn't return*
- Used when an assigment is done on a function call but the infered function
+ Used when an assignment is done on a function call but the inferred function
doesn't return anything.
:W1111: *Assigning to function call which only returns None*
- Used when an assigment is done on a function call but the infered function
+ Used when an assignment is done on a function call but the inferred function
returns nothing but None.
@@ -430,7 +430,7 @@ Classes checker
checks for :
* methods without self as first argument
* overridden methods signature
-* access only to existant members via self
+* access only to existent members via self
* attributes not defined in the __init__ method
* supported interfaces implementation
* unreachable code
@@ -450,7 +450,7 @@ Options
Messages
~~~~~~~~
:E0202: *An attribute inherited from %s hide this method*
- Used when a class defines a method which is hiden by an instance attribute
+ Used when a class defines a method which is hidden by an instance attribute
from an ancestor class.
:E0203: *Access to member %r before its definition line %s*
Used when an instance member is accessed before it's actually assigned.
@@ -459,8 +459,8 @@ Messages
no argument defined.
:E0213: *Method should have "self" as first argument*
Used when a method has an attribute different the "self" as first argument.
- This is considered as an error since this is a soooo common convention that
- you should'nt break it!
+ This is considered as an error since this is a so common convention that
+ you shouldn't break it!
:E0221: *Interface resolved to %s is not a class*
Used when a class claims to implement an interface which is not a class.
:E0222: *Missing method %r from %s interface*
@@ -481,7 +481,7 @@ Messages
Used when a method signature is different than in the implemented interface or
in an overridden method.
:W0223: *Method %r is abstract in class %r but is not overridden*
- Used when an abstract method (ie raise NotImplementedError) is not overridden
+ Used when an abstract method (i.e. raise NotImplementedError) is not overridden
in concrete class.
:W0231: *__init__ method from base class %r is not called*
Used when an ancestor class method has an __init__ method which is not called
@@ -502,7 +502,7 @@ Messages
argument.
:F0202: *Unable to check methods signature (%s / %s)*
Used when PyLint has been unable to check methods signature compatibility for
- an unexpected raison. Please report this kind if you don't make sense of it.
+ an unexpected reason. Please report this kind if you don't make sense of it.
:F0220: *failed to resolve interfaces implemented by %s (%s)*
Used when a PyLint as failed to find interfaces implemented by a class
@@ -714,7 +714,7 @@ Messages
:C0301: *Line too long (%s/%s)*
Used when a line is longer than a given number of characters.
:C0302: *Too many lines in module (%s)*
- Used when a module has too much lines, reducing its readibility.
+ Used when a module has too much lines, reducing its readability.
:C0321: *More than one statement on a single line*
Used when more than on statement are found on the same line.
:C0322: *Operator not preceded by a space*
@@ -726,7 +726,7 @@ Messages
:C0324: *Comma not followed by a space*
Used when a comma (",") is not followed by a space.
:F0321: *Format detection error in %r*
- Used when an unexpected error occured in bad format detection.Please report
+ Used when an unexpected error occurred in bad format detection.Please report
the error if it occurs.
diff --git a/doc/manual.txt b/doc/manual.txt
index a0ff8d1..eb40cdf 100644
--- a/doc/manual.txt
+++ b/doc/manual.txt
@@ -26,7 +26,7 @@ What is pylint?
Pylint is a tool that checks for errors in python code, tries to enforce a
coding standard and looks for smelling code. This is similar but nevertheless
-different from what pychecker_ provides, especially since pychecker explicitely
+different from what pychecker_ provides, especially since pychecker explicitly
does not bother with coding style. The default coding style used by pylint is
close to `PEP 008`_ (aka `Guido's style guide`_). For more information about
code smells, refer to Martin Fowler's `refactoring book`_
@@ -58,7 +58,7 @@ programmers.
Installation
------------
-Dependancies
+Dependencies
''''''''''''
Pylint requires the latest `logilab-astng`_ and `logilab-common`_
packages. It should be compatible with any python version greater than
@@ -85,7 +85,7 @@ Contributed RPM packages for pylint and logilab-common are available at
ftp://ftp.nest.pld-linux.org/test.
Pylint is also available in Gentoo, Fedora 4, Ubuntu, FreeBSD, Darwin
-(and maybe other, if si drop us a note please!).
+(and maybe others, if you know about more OSes, please drop us a note!).
Source distribution installation
@@ -95,7 +95,7 @@ directory and simply run ::
python setup.py install
-You'll have to install dependancies in a similar way.
+You'll have to install dependencies in a similar way.
Windows users may get valuable information about pylint installation on
`this page`_.
@@ -229,14 +229,14 @@ Example (extracted from a run of pylint on itself...):
W: 74:searchall: Unreachable code
W:171:FormatChecker.process_tokens: Redefining built-in (type)
W:150:FormatChecker.process_tokens: Too many local variables (20/15)
- W:150:FormatChecker.process_tokens: Too many branchs (13/12)
+ W:150:FormatChecker.process_tokens: Too many branches (13/12)
Reports section
'''''''''''''''
Following the analysis message, pylint will display a set of reports,
each one focusing on a particular aspect of the project, such as number
-of messages by categories, modules dependancies...
+of messages by categories, modules dependencies...
For instance, the metrics report displays summaries gathered from the
current run.
@@ -247,7 +247,7 @@ current run.
* percentage of classes, functions and modules with docstrings, and
a comparison from the previous run
* percentage of classes, functions and modules with correct name
- (according the the coding standard), and a comparison from the
+ (according to the coding standard), and a comparison from the
previous run
* a list of external dependencies found in the code, and where they appear
@@ -314,11 +314,11 @@ python makes it hard enough, it is not the case for warnings.
:Quoting Alexandre:
My usage pattern for pylint is to generally run pylint -e quite often to
get stupid errors flagged before launching an application (or before
- comitting). I generally run pylint with all the bells and whistles
+ committing). I generally run pylint with all the bells and whistles
activated some time before a release, when I want to cleanup the code.
And when I do that I simply ignore tons of the false warnings (and I
can do that without being driven mad by this dumb program which is not
- smart enough to understand the dynamicity of Python because I only run
+ smart enough to understand the dynamically of Python because I only run
it once or twice a week in this mode)
:Quoting Marteen Ter Huurne:
@@ -356,7 +356,7 @@ You can check for already reported bugs, planned features on pylint's tracker
web page: http://www.logilab.org/project/name/pylint
Notice that if you don't find something you have expected in pylint's
-tracker page, it may be on the tracker page of one of its dependancies, namely
+tracker page, it may be on the tracker page of one of its dependencies, namely
astng and common:
* http://www.logilab.org/project/name/logilab-astng
@@ -553,7 +553,7 @@ ask for any information on the python-projects mailing list.
Contribute !
------------
-All our software is developped using the mercurial_ version control
+All our software is developed using the mercurial_ version control
system. This is a very cool distributed vcs and its usage is very similar to
other ones such as cvs or subversion (though the distributed feature introduced
some different usage patterns). See mercurial home page for installation on
@@ -565,7 +565,7 @@ repository:
http://www.logilab.org/src/pylint
-The same is true for pylint dependancies (if you use pylint code from the
+The same is true for pylint dependencies (if you use pylint code from the
repository, you should usually use code from the repository as well for astng
and common):
diff --git a/doc/quickstart.txt b/doc/quickstart.txt
index 61a0e54..1915678 100644
--- a/doc/quickstart.txt
+++ b/doc/quickstart.txt
@@ -124,7 +124,7 @@ Example (extracted from a run of pylint on itself...):
W: 74:searchall: Unreachable code
W:171:FormatChecker.process_tokens: Redefining built-in (type)
W:150:FormatChecker.process_tokens: Too many local variables (20/15)
- W:150:FormatChecker.process_tokens: Too many branchs (13/12)
+ W:150:FormatChecker.process_tokens: Too many branches (13/12)
Reports section
@@ -132,7 +132,7 @@ Reports section
Following the analysis message, pylint will display a set of reports,
each one focusing on a particular aspect of the project, such as number
-of messages by categories, modules dependancies...
+of messages by categories, modules dependencies...
For instance, the metrics report displays summaries gathered from the
current run.
@@ -143,7 +143,7 @@ current run.
* percentage of classes, functions and modules with docstrings, and
a comparison from the previous run
* percentage of classes, functions and modules with correct name
- (according the the coding standard), and a comparison from the
+ (according to the coding standard), and a comparison from the
previous run
* a list of external dependencies found in the code, and where they appear