diff options
author | Pierre Sassoulas <pierre.sassoulas@gmail.com> | 2021-04-04 23:21:02 +0200 |
---|---|---|
committer | Pierre Sassoulas <pierre.sassoulas@gmail.com> | 2021-04-05 15:08:27 +0200 |
commit | 4d729a0bb63b6269a4667645008dde8762414769 (patch) | |
tree | d7682a47775b7e8a914c3e6de21c9b8983f51976 /setup.py | |
parent | a51786a9a2e98af61e952aaf6b0cb88780866f5b (diff) | |
download | pylint-git-4d729a0bb63b6269a4667645008dde8762414769.tar.gz |
Handle the version in setup.cfg (as well as everything else)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 14 |
1 files changed, 1 insertions, 13 deletions
@@ -1,16 +1,4 @@ -# Licensed under the GPL: https://www.gnu.org/licenses/old-licenses/gpl-2.0.html -# For details: https://github.com/PyCQA/pylint/blob/master/COPYING - -from pathlib import Path -from typing import Any, Dict - from setuptools import setup -HERE = Path(__file__).parent - -__pkginfo__: Dict[str, Any] = {} -with open(HERE / "pylint/__pkginfo__.py", encoding="UTF-8") as f: - exec(f.read(), __pkginfo__) # pylint: disable=exec-used - if __name__ == "__main__": - setup(version=__pkginfo__["__version__"]) + setup() |