diff options
author | T.Rzepka <Tobias.Rzepka@gmail.com> | 2013-09-21 22:51:43 +0200 |
---|---|---|
committer | T.Rzepka <Tobias.Rzepka@gmail.com> | 2013-09-21 22:51:43 +0200 |
commit | 0380c5aa291c96e808d5e63bc1e0f398df0306f2 (patch) | |
tree | 7c3d42801234e2a8e100618c264146f803ba9f9b /setup.py | |
parent | 3ee510715a8cafca727c94c4568af461c4387b9d (diff) | |
download | pylint-git-0380c5aa291c96e808d5e63bc1e0f398df0306f2.tar.gz |
#51: Building pylint Windows installer for Python3 fails
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 7 insertions, 1 deletions
@@ -121,6 +121,12 @@ class MyInstallLib(install_lib.install_lib): base = join(subpackage_of, modname) else: base = modname + if sys.platform == 'win32': + two_to_three = [sys.executable] + exe_path = os.path.dirname(sys.executable) + two_to_three.append(os.path.join(exe_path, 'Tools\\Scripts\\2to3.py')) + else: + two_to_three = ['2to3'] for directory in include_dirs: dest = join(self.install_dir, base, directory) if sys.version_info >= (3, 0): @@ -135,7 +141,7 @@ class MyInstallLib(install_lib.install_lib): # process manually python file in include_dirs (test data) from subprocess import call print('running 2to3 on', dest) - call(['2to3', '-wn', dest]) + call(two_to_three + ['-wn', dest]) def install(**kwargs): |