summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatryk Zawadzki <patrys@room-303.com>2013-11-07 11:57:21 +0100
committerPatryk Zawadzki <patrys@room-303.com>2013-11-07 11:57:21 +0100
commit3bb76c110d4b43f713a5d4a63933b88ff67ac04d (patch)
tree5fa39de005c5673129eb0398b6c0032bcefc5cb5
parent9872a811f33f7843411431f3e0e12b2cc56c7f2d (diff)
downloadpyjwt-3bb76c110d4b43f713a5d4a63933b88ff67ac04d.tar.gz
Announce Python 3 support
Also let `./setup.py test` work in Python 2
-rwxr-xr-xsetup.py27
-rw-r--r--tests/__init__.py0
2 files changed, 16 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 6314139..7fd99a4 100755
--- a/setup.py
+++ b/setup.py
@@ -2,25 +2,30 @@
import os
from setuptools import setup
+
def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
setup(
- name = "PyJWT",
- version = "0.1.6",
- author = "Jeff Lindsay",
- author_email = "jeff.lindsay@twilio.com",
- description = ("JSON Web Token implementation in Python"),
- license = "MIT",
- keywords = "jwt json web token security signing",
- url = "http://github.com/progrium/pyjwt",
+ name="PyJWT",
+ version="0.1.6",
+ author="Jeff Lindsay",
+ author_email="jeff.lindsay@twilio.com",
+ description="JSON Web Token implementation in Python",
+ license="MIT",
+ keywords="jwt json web token security signing",
+ url="http://github.com/progrium/pyjwt",
packages=['jwt'],
scripts=['bin/jwt'],
long_description=read('README.md'),
classifiers=[
"Development Status :: 3 - Alpha",
- "Topic :: Utilities",
"License :: OSI Approved :: MIT License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Topic :: Utilities",
],
- test_suite='tests.test_jwt'
-)
+ test_suite='tests.test_jwt')
diff --git a/tests/__init__.py b/tests/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/__init__.py