summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Cannon <brett@python.org>2020-05-11 19:58:14 -0700
committerGitHub <noreply@github.com>2020-05-11 19:58:14 -0700
commitcd261abfe4cf7fcdaac5cef657ae3a16205fa0d7 (patch)
tree6aecc6926005df525d963663c13b84603d73f70a
parentda385d5d65c6f515ae0ca88338b0a2e7a5c19c9c (diff)
downloadpyflakes-cd261abfe4cf7fcdaac5cef657ae3a16205fa0d7.tar.gz
List Python 3.8 support (#541)
* Add Python 3.8 to Travis * Add Python 3.8 to Tox * Add Python 3.8 trove classifier * List Python 3.8 as supported in the README
-rw-r--r--.travis.yml2
-rw-r--r--README.rst2
-rwxr-xr-xsetup.py1
-rw-r--r--tox.ini2
4 files changed, 5 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index e51b2e0..6babe1d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,6 +10,8 @@ matrix:
- python: pypy3
- python: 3.7
dist: xenial
+ - python: 3.8
+ dist: xenial
- python: nightly
dist: xenial
# TODO: https://bugs.python.org/issue40334
diff --git a/README.rst b/README.rst
index ca802a8..fb13fdf 100644
--- a/README.rst
+++ b/README.rst
@@ -9,7 +9,7 @@ parsing the source file, not importing it, so it is safe to use on
modules with side effects. It's also much faster.
It is `available on PyPI <https://pypi.org/project/pyflakes/>`_
-and it supports all active versions of Python: 2.7 and 3.4 to 3.7.
+and it supports all active versions of Python: 2.7 and 3.4 to 3.8.
diff --git a/setup.py b/setup.py
index 5e2088e..e4d709d 100755
--- a/setup.py
+++ b/setup.py
@@ -58,6 +58,7 @@ setup(
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development",
diff --git a/tox.ini b/tox.ini
index f2256c8..7365833 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
skip_missing_interpreters = True
envlist =
- py27,py34,py35,py36,py37,pypy,pypy3
+ py27,py34,py35,py36,py37,py38,pypy,pypy3
[testenv]
deps = flake8==3.6.0