summaryrefslogtreecommitdiff
path: root/src/c/liberasurecode/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/c/liberasurecode/doc/Makefile.am')
-rw-r--r--src/c/liberasurecode/doc/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/c/liberasurecode/doc/Makefile.am b/src/c/liberasurecode/doc/Makefile.am
new file mode 100644
index 0000000..31804cb
--- /dev/null
+++ b/src/c/liberasurecode/doc/Makefile.am
@@ -0,0 +1,36 @@
+DOC_MODULE="liberasurecode"
+HTML_DIR=$(datadir)/$(DOC_MODULE)/html
+TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+
+all-local: html/index.html
+
+if ENABLE_DOXYGEN
+html/index.html: doxygen.cfg
+ doxygen doxygen.cfg
+else
+html/index.html:
+endif
+
+clean-local:
+ rm -f *~ *.bak
+ rm -rf html
+
+install-data-local: html
+ ../install-sh -d $(DESTDIR)$(TARGET_DIR)
+ (installfiles=`echo html/*`; \
+ if test "$$installfiles" = 'html/*'; \
+ then echo '-- Nothing to install' ; \
+ else \
+ for i in $$installfiles; do \
+ echo '-- Installing '$$i ; \
+ ../install-sh $$i $(DESTDIR)$(TARGET_DIR); \
+ done; \
+ fi)
+
+dist-hook:
+ mkdir $(distdir)/html
+ mkdir $(distdir)/man
+ -cp html/* $(distdir)/html
+ -cp man/* $(distdir)/man
+
+.PHONY : html latex man