summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2015-03-10 23:18:35 -0700
committerTushar Gohad <tushar.gohad@intel.com>2015-03-11 00:31:35 -0700
commit31c85bd12b5196409f8a61813dc179ad142b3897 (patch)
tree6b532e6554d566f28dafdd57ceb46bd30c5d65c6
parent92ad540101ef2f2086807916c0db29c3a9237e91 (diff)
downloadpyeclib-31c85bd12b5196409f8a61813dc179ad142b3897.tar.gz
Append local paths to default_include_paths during "build"
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index af6f99b..42c9b6b 100644
--- a/setup.py
+++ b/setup.py
@@ -119,12 +119,13 @@ def _check_library(library, soname, library_url, mode, distribution):
libflags = ""
for d in libdirs:
libflags = libflags + " -L" + d
- default_library_paths.insert(0, d)
+ default_library_paths.append(d)
includeflags = " -I" + topdir + "/" + locallibsrcdir + "/include"
for subdir in os.walk(topdir + "/" + locallibsrcdir + "/include"):
if (os.path.isdir(subdir[0])):
includeflags = includeflags + " -I" + subdir[0]
+ default_include_paths.append(subdir[0])
curdir = os.getcwd()
os.chdir(locallibsrcdir)