diff options
author | Tushar Gohad <tushar.gohad@intel.com> | 2015-03-13 00:24:40 -0700 |
---|---|---|
committer | Tushar Gohad <tushar.gohad@intel.com> | 2015-03-13 01:09:49 -0700 |
commit | df9c297d674efa9e1928f085bdff83e313762eb9 (patch) | |
tree | 320aebeda5fc9d0f337abadefb2c679660c318f9 | |
parent | 16cbe3c9f6ac9ebd392d8fc95bef2e7b59d127d9 (diff) | |
download | pyeclib-df9c297d674efa9e1928f085bdff83e313762eb9.tar.gz |
Minor ld-related message cleanup in setup.py
-rw-r--r-- | setup.py | 50 |
1 files changed, 19 insertions, 31 deletions
@@ -129,42 +129,30 @@ class install(_install): default_library_paths.insert(0, "%s/usr/local/lib" % installroot) _install.run(self) - # # Another Mac-ism... If the libraries are installed # in a strange place, DYLD_LIRBARY_PATH needs to be # updated. - # if platform_str.find("Darwin") > -1: - print("***************************************************") - print("** ") - print("** You are running on a Mac! This means that ") - print("** any user using this library must update: ") - print("** DYLD_LIBRARY_PATH ") - print("** ") - print("** The best way to do this is to put this line:") - print("** export DYLD_LIBRARY_PATH=%s" % ("%s/usr/local/lib" - % installroot)) - print("** ") - print("** into .bashrc, .profile, or the appropriate") - print("** shell start-up script!") - print("***************************************************") + ldpath_str = "DYLD_LIBRARY_PATH" else: - print("***************************************************") - print("** ") - print("** PyECLib libraries have been installed to: ") - print("** %susr/local/lib" % installroot) - print("** ") - print("** Any user using this library must update: ") - print("** LD_LIBRARY_PATH ") - print("** ") - print("** The best way to do this is to put this line:") - print("** export LD_LIBRARY_PATH=%s" % ("%susr/local/lib" - % installroot)) - print("** ") - print("** into .bashrc, .profile, or the appropriate shell") - print("** start-up script! Also look at ldconfig(8) man") - print("** page for a more static LD configuration") - print("***************************************************") + ldpath_str = "LD_LIBRARY_PATH" + print("***************************************************") + print("** ") + print("** PyECLib libraries have been installed to: ") + print("** %susr/local/lib" % installroot) + print("** ") + print("** Any user using this library must update: ") + print("** %s" % ldpath_str) + print("** ") + print("** The best way to do this is to put this line: ") + print("** export %s=%s" % (ldpath_str, "%susr/local/lib" + % installroot)) + print("** ") + print("** into .bashrc, .profile, or the appropriate shell") + print("** start-up script! Also look at ldconfig(8) man ") + print("** page for a more static LD configuration ") + print("** ") + print("***************************************************") module = Extension('pyeclib_c', |