summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-06-26 06:12:16 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-06-26 06:12:16 -0700
commit9e33dc7875eef8c01d8f31e9bf9a120d6ed48945 (patch)
treea9f9435a555a0f369fc6b8b5c0263dfdd2ded50b
parent5fadc482b6aa0f006a146509c91b52e94ff5056a (diff)
downloadpyeclib-9e33dc7875eef8c01d8f31e9bf9a120d6ed48945.tar.gz
pyeclib_c: Split include, core, integrity_util
Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
-rw-r--r--setup.py6
-rw-r--r--src/c/include/alg_sig.h50
-rw-r--r--src/c/include/capsulethunk.h (renamed from src/c/pyeclib_c/capsulethunk.h)0
-rw-r--r--src/c/include/pyeclib_c.h (renamed from src/c/pyeclib_c/pyeclib_c.h)0
-rw-r--r--src/c/integrity_util/alg_sig.c344
-rw-r--r--src/c/integrity_util/crc32.c132
6 files changed, 530 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 6a134f9..ddb91fe 100644
--- a/setup.py
+++ b/setup.py
@@ -147,7 +147,7 @@ module = Extension('pyeclib_c',
'/usr/local/include',
'/usr/local/include/jerasure',
'/usr/include',
- 'src/c/pyeclib_c',
+ 'src/c/include',
'/usr/local/include'],
library_dirs=default_library_paths,
runtime_library_dirs=default_library_paths,
@@ -156,7 +156,9 @@ module = Extension('pyeclib_c',
# extra_compile_args=['-g', '-O0'],
extra_link_args=['-Wl,-rpath,%s' %
l for l in default_library_paths],
- sources=['src/c/pyeclib_c/pyeclib_c.c'])
+ sources=['src/c/pyeclib_c/pyeclib_c.c',
+ 'src/c/integrity_util/alg_sig.c',
+ 'src/c/integrity_util/crc32.c'])
setup(name='PyECLib',
version='0.10.0',
diff --git a/src/c/include/alg_sig.h b/src/c/include/alg_sig.h
new file mode 100644
index 0000000..f838d7b
--- /dev/null
+++ b/src/c/include/alg_sig.h
@@ -0,0 +1,50 @@
+/* * Copyright (c) 2013, Kevin Greenan (kmgreen2@gmail.com)
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *
+ * Redistributions of source code must retain the above copyright notice, this
+ * list of conditions and the following disclaimer.
+ *
+ * Redistributions in binary form must reproduce the above copyright notice, this
+ * list of conditions and the following disclaimer in the documentation and/or
+ * other materials provided with the distribution. THIS SOFTWARE IS PROVIDED BY
+ * THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
+ * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+ * EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
+ * INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+ * BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+ * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
+ * OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+ * ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#ifndef _ALG_SIG_H
+#define _ALG_SIG_H
+
+#include<galois.h>
+
+typedef struct alg_sig_s
+{
+ int gf_w;
+ int sig_len;
+ int *tbl1_l;
+ int *tbl1_r;
+ int *tbl2_l;
+ int *tbl2_r;
+ int *tbl3_l;
+ int *tbl3_r;
+} alg_sig_t;
+
+alg_sig_t *init_alg_sig(int sig_len, int gf_w);
+void destroy_alg_sig(alg_sig_t* alg_sig_handle);
+
+int compute_alg_sig(alg_sig_t* alg_sig_handle, char *buf, int len, char *sig);
+int crc32_build_fast_table();
+int crc32(int crc, const void *buf, int size);
+
+#endif
+
diff --git a/src/c/pyeclib_c/capsulethunk.h b/src/c/include/capsulethunk.h
index 6dca150..6dca150 100644
--- a/src/c/pyeclib_c/capsulethunk.h
+++ b/src/c/include/capsulethunk.h
diff --git a/src/c/pyeclib_c/pyeclib_c.h b/src/c/include/pyeclib_c.h
index fdd2f43..fdd2f43 100644
--- a/src/c/pyeclib_c/pyeclib_c.h
+++ b/src/c/include/pyeclib_c.h
diff --git a/src/c/integrity_util/alg_sig.c b/src/c/integrity_util/alg_sig.c
new file mode 100644
index 0000000..02478b0
--- /dev/null
+++ b/src/c/integrity_util/alg_sig.c
@@ -0,0 +1,344 @@
+/* * Copyright (c) 2013, Kevin Greenan (kmgreen2@gmail.com)
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *
+ * Redistributions of source code must retain the above copyright notice, this
+ * list of conditions and the following disclaimer.
+ *
+ * Redistributions in binary form must reproduce the above copyright notice, this
+ * list of conditions and the following disclaimer in the documentation and/or
+ * other materials provided with the distribution. THIS SOFTWARE IS PROVIDED BY
+ * THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
+ * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+ * EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
+ * INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+ * BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+ * LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
+ * OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+ * ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include<alg_sig.h>
+#include<stdlib.h>
+#include<string.h>
+
+int valid_gf_w[] = { 8, 16, -1 };
+int valid_pairs[][2] = { { 8, 32}, {16, 32}, {16, 64}, {-1, -1} };
+
+
+static
+alg_sig_t *init_alg_sig_w8(int sig_len)
+{
+ alg_sig_t *alg_sig_handle;
+ int num_gf_lr_table_syms;
+ int i;
+ int w = 8;
+ int alpha = 2, beta = 4, gamma = 8;
+ int num_components = sig_len / w;
+
+ alg_sig_handle = (alg_sig_t *)malloc(sizeof(alg_sig_t));
+ if (alg_sig_handle == NULL) {
+ return NULL;
+ }
+
+ alg_sig_handle->sig_len = sig_len;
+ alg_sig_handle->gf_w = w;
+
+ num_gf_lr_table_syms = 1 << (w >> 1);
+
+ if (num_components >= 4) {
+ alg_sig_handle->tbl1_l = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl1_r = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl2_l = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl2_r = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl3_l = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl3_r = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ }
+
+ /*
+ * Note that \alpha = 2
+ * Note that \beta = 4 (\alpha ^ 2)
+ * Note that \gamme = 8 (\alpha ^ 3)
+ */
+ for (i = 0; i < 16; i++) {
+ if (num_components >= 4) {
+ alg_sig_handle->tbl1_l[i] = galois_single_multiply((unsigned char) (i << 4) & 0xf0, alpha, w);
+ alg_sig_handle->tbl1_r[i] = galois_single_multiply((unsigned char) i, alpha, w);
+
+ alg_sig_handle->tbl2_l[i] = galois_single_multiply((unsigned char) (i << 4) & 0xf0, beta, w);
+ alg_sig_handle->tbl2_r[i] = galois_single_multiply((unsigned char) i, beta, w);
+
+ alg_sig_handle->tbl3_l[i] = galois_single_multiply((unsigned char) (i << 4) & 0xf0, gamma, w);
+ alg_sig_handle->tbl3_r[i] = galois_single_multiply((unsigned char) i, gamma, w);
+ }
+ }
+
+ return alg_sig_handle;
+}
+
+static
+alg_sig_t *init_alg_sig_w16(int sig_len)
+{
+ alg_sig_t *alg_sig_handle;
+ int num_gf_lr_table_syms;
+ int i;
+ int w = 16;
+ int alpha = 2, beta = 4, gamma = 8;
+ int num_components = sig_len / w;
+
+ alg_sig_handle = (alg_sig_t *)malloc(sizeof(alg_sig_t));
+ if (alg_sig_handle == NULL) {
+ return NULL;
+ }
+
+ alg_sig_handle->sig_len = sig_len;
+ alg_sig_handle->gf_w = w;
+
+ num_gf_lr_table_syms = 1 << (w >> 1);
+
+ if (num_components >= 2) {
+ alg_sig_handle->tbl1_l = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl1_r = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ }
+
+ if (num_components >= 4) {
+ alg_sig_handle->tbl2_l = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl2_r = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl3_l = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ alg_sig_handle->tbl3_r = (int*)malloc(sizeof(int) * num_gf_lr_table_syms);
+ }
+
+ /*
+ * Note that \alpha = 2
+ * Note that \beta = 4 (\alpha ^ 2 MOD 2^16)
+ * Note that \gamme = 8 (\alpha ^ 3 MOD 2^16)
+ */
+ for (i = 0; i < 256; i++) {
+ alg_sig_handle->tbl1_l[i] = galois_single_multiply((unsigned short) (i << 8), alpha, w);
+ alg_sig_handle->tbl1_r[i] = galois_single_multiply((unsigned short) i, alpha, w);
+
+ if (num_components >= 4) {
+ alg_sig_handle->tbl2_l[i] = galois_single_multiply((unsigned short) (i << 8), beta, w);
+ alg_sig_handle->tbl2_r[i] = galois_single_multiply((unsigned short) i, beta, w);
+
+ alg_sig_handle->tbl3_l[i] = galois_single_multiply((unsigned short) (i << 8), gamma, w);
+ alg_sig_handle->tbl3_r[i] = galois_single_multiply((unsigned short) i, gamma, w);
+ }
+ }
+
+ return alg_sig_handle;
+}
+
+alg_sig_t *init_alg_sig(int sig_len, int gf_w)
+{
+ int i=0;
+ while (valid_pairs[i][0] > -1) {
+ if (gf_w == valid_pairs[i][0] &&
+ sig_len == valid_pairs[i][1]) {
+ break;
+ }
+ i++;
+ }
+
+ if (valid_pairs[i][0] == -1) {
+ return NULL;
+ }
+
+ if (gf_w == 8) {
+ return init_alg_sig_w8(sig_len);
+ } else if (gf_w == 16) {
+ return init_alg_sig_w16(sig_len);
+ }
+ return NULL;
+}
+
+void destroy_alg_sig(alg_sig_t* alg_sig_handle)
+{
+ if (alg_sig_handle == NULL) {
+ return;
+ }
+ if (alg_sig_handle->gf_w == 0) {
+ free(alg_sig_handle);
+ return;
+ }
+ int num_components = alg_sig_handle->sig_len / alg_sig_handle->gf_w;
+
+ free(alg_sig_handle->tbl1_l);
+ free(alg_sig_handle->tbl1_r);
+ if (num_components >= 4) {
+ free(alg_sig_handle->tbl2_l);
+ free(alg_sig_handle->tbl2_r);
+ free(alg_sig_handle->tbl3_l);
+ free(alg_sig_handle->tbl3_r);
+ }
+ free(alg_sig_handle);
+}
+
+
+static
+int compute_w8_alg_sig_32(alg_sig_t *alg_sig_handle, char *buf, int len, char *sig)
+{
+ int bit_mask;
+ int i;
+ int alpha = 2, beta = 4, gamma = 8;
+ int w = 8;
+
+ if (len == 0) {
+ bzero(sig, 4);
+ return 0;
+ }
+
+ sig[0] = buf[len-1];
+ sig[1] = buf[len-1];
+ sig[2] = buf[len-1];
+ sig[3] = buf[len-1];
+
+ /**
+ * This is the loop to optimize. It is currently optimized enough : using Horner's alg.,
+ * shortened mult. tables, and other tricks.
+ */
+ for (i = len - 2; i >= 0; i--) {
+ sig[0] ^= buf[i];
+ sig[1] = (buf[i] ^ (alg_sig_handle->tbl1_l[(sig[1] >> 4) & 0x0f] ^ alg_sig_handle->tbl1_r[sig[1] & 0x0f]));
+ sig[2] = (buf[i] ^ (alg_sig_handle->tbl2_l[(sig[2] >> 4) & 0x0f] ^ alg_sig_handle->tbl2_r[sig[2] & 0x0f]));
+ sig[3] = (buf[i] ^ (alg_sig_handle->tbl3_l[(sig[3] >> 4) & 0x0f] ^ alg_sig_handle->tbl3_r[sig[3] & 0x0f]));
+ }
+
+ return 0;
+}
+
+static
+int compute_w16_alg_sig_64(alg_sig_t *alg_sig_handle, char *buf, int len, char *sig)
+{
+ int bit_mask;
+ int adj_len = len / 2;
+ int i;
+ unsigned short *_buf = (unsigned short *)buf;
+ unsigned short sig_buf[4];
+
+ if (len == 0) {
+ bzero(sig, 8);
+ return 0;
+ }
+
+ switch (len % 2) {
+ case 1:
+ bit_mask = 0x00ff;
+ break;
+ default:
+ bit_mask = 0xffff;
+ break;
+ }
+
+ if (len % 2 > 0) {
+ adj_len++;
+ }
+
+ // Account for buffer not being uint16_t aligned
+ sig_buf[0] = (_buf[adj_len - 1] & bit_mask);
+ sig_buf[1] = (_buf[adj_len - 1] & bit_mask);
+ sig_buf[2] = (_buf[adj_len - 1] & bit_mask);
+ sig_buf[3] = (_buf[adj_len - 1] & bit_mask);
+
+ /**
+ * This is the loop to optimize. It is currently optimized enough : using Horner's alg.,
+ * shortened mult. tables, and other tricks.
+ */
+ for (i = adj_len - 2; i >= 0; i--) {
+ sig_buf[0] ^= _buf[i];
+ sig_buf[1] = (_buf[i] ^ (alg_sig_handle->tbl1_l[(sig_buf[1] >> 8) & 0x00ff] ^ alg_sig_handle->tbl1_r[sig_buf[1] & 0x00ff]));
+ sig_buf[2] = (_buf[i] ^ (alg_sig_handle->tbl2_l[(sig_buf[2] >> 8) & 0x00ff] ^ alg_sig_handle->tbl2_r[sig_buf[2] & 0x00ff]));
+ sig_buf[3] = (_buf[i] ^ (alg_sig_handle->tbl3_l[(sig_buf[3] >> 8) & 0x00ff] ^ alg_sig_handle->tbl3_r[sig_buf[3] & 0x00ff]));
+ }
+
+ sig[0] = (char) (sig_buf[0] & 0x000ff);
+ sig[1] = (char) ((sig_buf[0] >> 8) & 0x000ff);
+ sig[2] = (char) (sig_buf[1] & 0x00ff);
+ sig[3] = (char) ((sig_buf[1] >> 8) & 0x00ff);
+ sig[4] = (char) (sig_buf[2] & 0x00ff);
+ sig[5] = (char) ((sig_buf[2] >> 8) & 0x00ff);
+ sig[6] = (char) (sig_buf[3] & 0x00ff);
+ sig[7] = (char) ((sig_buf[3] >> 8) & 0x00ff);
+ return 0;
+}
+
+static
+int compute_w16_alg_sig_32(alg_sig_t *alg_sig_handle, char *buf, int len, char *sig)
+{
+ int bit_mask;
+ int adj_len = len / 2;
+ int i;
+ unsigned short *_buf = (unsigned short *)buf;
+ unsigned short sig_buf[2];
+
+ if (len == 0) {
+ bzero(sig, 8);
+ return 0;
+ }
+
+ switch (len % 2) {
+ case 1:
+ bit_mask = 0x00ff;
+ break;
+ default:
+ bit_mask = 0xffff;
+ break;
+ }
+
+ if (len % 2 > 0) {
+ adj_len++;
+ }
+
+ // Account for buffer not being uint16_t aligned
+ sig_buf[0] = (_buf[adj_len - 1] & bit_mask);
+ sig_buf[1] = (_buf[adj_len - 1] & bit_mask);
+
+ /**
+ * This is the loop to optimize. It is currently optimized enough : using Horner's alg.,
+ * shortened mult. tables, and other tricks.
+ */
+ for (i = adj_len - 2; i >= 0; i--) {
+ sig_buf[0] ^= _buf[i];
+ sig_buf[1] = (_buf[i] ^ (alg_sig_handle->tbl1_l[(sig_buf[1] >> 8) & 0x00ff] ^ alg_sig_handle->tbl1_r[sig_buf[1] & 0x00ff]));
+ }
+
+ sig[0] = (char) (sig_buf[0] & 0x000ff);
+ sig[1] = (char) ((sig_buf[0] >> 8) & 0x000ff);
+ sig[2] = (char) (sig_buf[1] & 0x00ff);
+ sig[3] = (char) ((sig_buf[1] >> 8) & 0x00ff);
+ return 0;
+}
+
+static
+int compute_alg_sig_32(alg_sig_t *alg_sig_handle, char *buf, int len, char *sig)
+{
+ if (alg_sig_handle->gf_w == 8) {
+ return compute_w8_alg_sig_32(alg_sig_handle, buf, len, sig);
+ } else if (alg_sig_handle->gf_w == 16) {
+ return compute_w16_alg_sig_32(alg_sig_handle, buf, len, sig);
+ }
+ return -1;
+}
+
+static
+int compute_alg_sig_64(alg_sig_t *alg_sig_handle, char *buf, int len, char *sig)
+{
+ if (alg_sig_handle->gf_w == 16) {
+ return compute_w16_alg_sig_64(alg_sig_handle, buf, len, sig);
+ }
+ return -1;
+}
+
+int compute_alg_sig(alg_sig_t *alg_sig_handle, char *buf, int len, char *sig)
+{
+ if (alg_sig_handle->sig_len == 32) {
+ return compute_alg_sig_32(alg_sig_handle, buf, len, sig);
+ } else if (alg_sig_handle->sig_len == 64) {
+ return compute_alg_sig_64(alg_sig_handle, buf, len, sig);
+ }
+ return -1;
+}
diff --git a/src/c/integrity_util/crc32.c b/src/c/integrity_util/crc32.c
new file mode 100644
index 0000000..6710dd7
--- /dev/null
+++ b/src/c/integrity_util/crc32.c
@@ -0,0 +1,132 @@
+/*-
+ * COPYRIGHT (C) 1986 Gary S. Brown. You may use this program, or
+ * code or tables extracted from it, as desired without restriction.
+ *
+ * First, the polynomial itself and its table of feedback terms. The
+ * polynomial is
+ * X^32+X^26+X^23+X^22+X^16+X^12+X^11+X^10+X^8+X^7+X^5+X^4+X^2+X^1+X^0
+ *
+ * Note that we take it "backwards" and put the highest-order term in
+ * the lowest-order bit. The X^32 term is "implied"; the LSB is the
+ * X^31 term, etc. The X^0 term (usually shown as "+1") results in
+ * the MSB being 1
+ *
+ * Note that the usual hardware shift register implementation, which
+ * is what we're using (we're merely optimizing it by doing eight-bit
+ * chunks at a time) shifts bits into the lowest-order term. In our
+ * implementation, that means shifting towards the right. Why do we
+ * do it this way? Because the calculated CRC must be transmitted in
+ * order from highest-order term to lowest-order term. UARTs transmit
+ * characters in order from LSB to MSB. By storing the CRC this way
+ * we hand it to the UART in the order low-byte to high-byte; the UART
+ * sends each low-bit to hight-bit; and the result is transmission bit
+ * by bit from highest- to lowest-order term without requiring any bit
+ * shuffling on our part. Reception works similarly
+ *
+ * The feedback terms table consists of 256, 32-bit entries. Notes
+ *
+ * The table can be generated at runtime if desired; code to do so
+ * is shown later. It might not be obvious, but the feedback
+ * terms simply represent the results of eight shift/xor opera
+ * tions for all combinations of data and CRC register values
+ *
+ * The values must be right-shifted by eight bits by the "updcrc
+ * logic; the shift must be unsigned (bring in zeroes). On some
+ * hardware you could probably optimize the shift in assembler by
+ * using byte-swap instructions
+ * polynomial $edb88320
+ *
+ *
+ * CRC32 code derived from work by Gary S. Brown.
+ */
+
+#include <sys/param.h>
+
+#if defined(INTEL_SSE4)
+#include <nmmintrin.h>
+
+int
+crc32(int crc, const void *buf, size_t size)
+{
+ unsigned long long *current = (unsigned long long*)buf;
+ unsigned char *current_char;
+
+ crc = crc ^ ~0U;
+
+ while(size >= 8) {
+ crc = _mm_crc32_u64(crc, *current++);
+ size -= 8;
+ }
+
+ current_char = (unsigned char*)current;
+ while (size--) {
+ crc = _mm_crc32_u8(crc, *current_char++);
+ }
+ return crc ^ ~0U;
+}
+#else
+
+static int crc32_tab[] = {
+ 0x00000000, 0x77073096, 0xee0e612c, 0x990951ba, 0x076dc419, 0x706af48f,
+ 0xe963a535, 0x9e6495a3, 0x0edb8832, 0x79dcb8a4, 0xe0d5e91e, 0x97d2d988,
+ 0x09b64c2b, 0x7eb17cbd, 0xe7b82d07, 0x90bf1d91, 0x1db71064, 0x6ab020f2,
+ 0xf3b97148, 0x84be41de, 0x1adad47d, 0x6ddde4eb, 0xf4d4b551, 0x83d385c7,
+ 0x136c9856, 0x646ba8c0, 0xfd62f97a, 0x8a65c9ec, 0x14015c4f, 0x63066cd9,
+ 0xfa0f3d63, 0x8d080df5, 0x3b6e20c8, 0x4c69105e, 0xd56041e4, 0xa2677172,
+ 0x3c03e4d1, 0x4b04d447, 0xd20d85fd, 0xa50ab56b, 0x35b5a8fa, 0x42b2986c,
+ 0xdbbbc9d6, 0xacbcf940, 0x32d86ce3, 0x45df5c75, 0xdcd60dcf, 0xabd13d59,
+ 0x26d930ac, 0x51de003a, 0xc8d75180, 0xbfd06116, 0x21b4f4b5, 0x56b3c423,
+ 0xcfba9599, 0xb8bda50f, 0x2802b89e, 0x5f058808, 0xc60cd9b2, 0xb10be924,
+ 0x2f6f7c87, 0x58684c11, 0xc1611dab, 0xb6662d3d, 0x76dc4190, 0x01db7106,
+ 0x98d220bc, 0xefd5102a, 0x71b18589, 0x06b6b51f, 0x9fbfe4a5, 0xe8b8d433,
+ 0x7807c9a2, 0x0f00f934, 0x9609a88e, 0xe10e9818, 0x7f6a0dbb, 0x086d3d2d,
+ 0x91646c97, 0xe6635c01, 0x6b6b51f4, 0x1c6c6162, 0x856530d8, 0xf262004e,
+ 0x6c0695ed, 0x1b01a57b, 0x8208f4c1, 0xf50fc457, 0x65b0d9c6, 0x12b7e950,
+ 0x8bbeb8ea, 0xfcb9887c, 0x62dd1ddf, 0x15da2d49, 0x8cd37cf3, 0xfbd44c65,
+ 0x4db26158, 0x3ab551ce, 0xa3bc0074, 0xd4bb30e2, 0x4adfa541, 0x3dd895d7,
+ 0xa4d1c46d, 0xd3d6f4fb, 0x4369e96a, 0x346ed9fc, 0xad678846, 0xda60b8d0,
+ 0x44042d73, 0x33031de5, 0xaa0a4c5f, 0xdd0d7cc9, 0x5005713c, 0x270241aa,
+ 0xbe0b1010, 0xc90c2086, 0x5768b525, 0x206f85b3, 0xb966d409, 0xce61e49f,
+ 0x5edef90e, 0x29d9c998, 0xb0d09822, 0xc7d7a8b4, 0x59b33d17, 0x2eb40d81,
+ 0xb7bd5c3b, 0xc0ba6cad, 0xedb88320, 0x9abfb3b6, 0x03b6e20c, 0x74b1d29a,
+ 0xead54739, 0x9dd277af, 0x04db2615, 0x73dc1683, 0xe3630b12, 0x94643b84,
+ 0x0d6d6a3e, 0x7a6a5aa8, 0xe40ecf0b, 0x9309ff9d, 0x0a00ae27, 0x7d079eb1,
+ 0xf00f9344, 0x8708a3d2, 0x1e01f268, 0x6906c2fe, 0xf762575d, 0x806567cb,
+ 0x196c3671, 0x6e6b06e7, 0xfed41b76, 0x89d32be0, 0x10da7a5a, 0x67dd4acc,
+ 0xf9b9df6f, 0x8ebeeff9, 0x17b7be43, 0x60b08ed5, 0xd6d6a3e8, 0xa1d1937e,
+ 0x38d8c2c4, 0x4fdff252, 0xd1bb67f1, 0xa6bc5767, 0x3fb506dd, 0x48b2364b,
+ 0xd80d2bda, 0xaf0a1b4c, 0x36034af6, 0x41047a60, 0xdf60efc3, 0xa867df55,
+ 0x316e8eef, 0x4669be79, 0xcb61b38c, 0xbc66831a, 0x256fd2a0, 0x5268e236,
+ 0xcc0c7795, 0xbb0b4703, 0x220216b9, 0x5505262f, 0xc5ba3bbe, 0xb2bd0b28,
+ 0x2bb45a92, 0x5cb36a04, 0xc2d7ffa7, 0xb5d0cf31, 0x2cd99e8b, 0x5bdeae1d,
+ 0x9b64c2b0, 0xec63f226, 0x756aa39c, 0x026d930a, 0x9c0906a9, 0xeb0e363f,
+ 0x72076785, 0x05005713, 0x95bf4a82, 0xe2b87a14, 0x7bb12bae, 0x0cb61b38,
+ 0x92d28e9b, 0xe5d5be0d, 0x7cdcefb7, 0x0bdbdf21, 0x86d3d2d4, 0xf1d4e242,
+ 0x68ddb3f8, 0x1fda836e, 0x81be16cd, 0xf6b9265b, 0x6fb077e1, 0x18b74777,
+ 0x88085ae6, 0xff0f6a70, 0x66063bca, 0x11010b5c, 0x8f659eff, 0xf862ae69,
+ 0x616bffd3, 0x166ccf45, 0xa00ae278, 0xd70dd2ee, 0x4e048354, 0x3903b3c2,
+ 0xa7672661, 0xd06016f7, 0x4969474d, 0x3e6e77db, 0xaed16a4a, 0xd9d65adc,
+ 0x40df0b66, 0x37d83bf0, 0xa9bcae53, 0xdebb9ec5, 0x47b2cf7f, 0x30b5ffe9,
+ 0xbdbdf21c, 0xcabac28a, 0x53b39330, 0x24b4a3a6, 0xbad03605, 0xcdd70693,
+ 0x54de5729, 0x23d967bf, 0xb3667a2e, 0xc4614ab8, 0x5d681b02, 0x2a6f2b94,
+ 0xb40bbe37, 0xc30c8ea1, 0x5a05df1b, 0x2d02ef8d
+};
+
+// Use same polynomial as Intel's SSE4 instruction!
+#define POLY_CRC_32 0x11EDC6F41
+
+int
+crc32(int crc, const void *buf, size_t size)
+{
+ const char *p;
+
+ p = buf;
+ crc = crc ^ ~0U;
+
+ while (size--)
+ crc = crc32_tab[(crc ^ *p++) & 0xFF] ^ (crc >> 8);
+
+ return crc ^ ~0U;
+}
+#endif
+