summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Bendersky <eliben@gmail.com>2016-10-27 20:15:49 -0700
committerEli Bendersky <eliben@gmail.com>2016-10-27 20:15:49 -0700
commitf29f92a8cdcf9bde985306f6ac9381ab89c1eaa4 (patch)
treea2aa7376f6e28172304cecb567e028091ea88022
parentf2275a68ed2204636b53685887c995d8d307b6c0 (diff)
downloadpycparser-f29f92a8cdcf9bde985306f6ac9381ab89c1eaa4.tar.gz
Prepare release 2.17
-rw-r--r--CHANGES5
-rw-r--r--README.rst2
-rw-r--r--TODO.txt8
-rw-r--r--pycparser/__init__.py2
-rw-r--r--setup.py2
5 files changed, 13 insertions, 6 deletions
diff --git a/CHANGES b/CHANGES
index 9c5e6a3..e9d293e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,8 @@
++ Version 2.17 (29.10.2016)
+
+ - Again functionality identical to 2.15 and 2.16; the difference is that the
+ tarball now contains Python files with properly set permissions.
+
+ Version 2.16 (18.10.2016)
- Functionally identical to 2.15, but fixes a packaging problem that caused
diff --git a/README.rst b/README.rst
index 7588cea..2d9c9a2 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,5 @@
===============
-pycparser v2.16
+pycparser v2.17
===============
:Author: `Eli Bendersky <http://eli.thegreenplace.net>`_
diff --git a/TODO.txt b/TODO.txt
index 4240e7b..d49312e 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -10,7 +10,7 @@ setup.py, __init__.py, README, CHANGES
- If PLY version changes, note it in README and ply/LICENSE
- Run tox tests
-python setup.py sdist upload
+python setup.py sdist
Misc
----
@@ -20,10 +20,12 @@ yacc optimization:
anyway, regardless of the optimize parameter
- If it does exist:
- If optimize=True, the table will be loaded unconditionally
- - If optimize=False, the table will be loaded only if it's older than the grammar
+ - If optimize=False, the table will be loaded only if it's older than the
+ grammar
lex optimization:
-- If optimize=False, the lexical table is re-computed and is not saved to a lextab file
+- If optimize=False, the lexical table is re-computed and is not saved to a
+ lextab file
- If optimize=True:
- If lextab.py/pyc exists in the path, it will be loaded unconditionally
- If lextab.py/pyc doesn't exist, it will be created and loaded
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index 74b2702..152a855 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -8,7 +8,7 @@
# License: BSD
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.16'
+__version__ = '2.17'
from subprocess import Popen, PIPE
from .c_parser import CParser
diff --git a/setup.py b/setup.py
index da2cda1..07a62da 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
C compilers or analysis tools.
""",
license='BSD',
- version='2.16',
+ version='2.17',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',