summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Bendersky <eliben@gmail.com>2016-10-18 06:14:24 -0700
committerEli Bendersky <eliben@gmail.com>2016-10-18 06:14:24 -0700
commit9e9855b3254a8e234ac8f793154d600905b90a55 (patch)
tree99fa93ea8a59a96d8260ca0533c188f24a5cabf3
parent6ba9544f597f12cee554da10bd7b6bb6a9650ed3 (diff)
downloadpycparser-9e9855b3254a8e234ac8f793154d600905b90a55.tar.gz
Prepare for releasing v2.15release_v2.15
-rw-r--r--CHANGES3
-rw-r--r--README.rst2
-rw-r--r--pycparser/__init__.py2
-rw-r--r--setup.py2
4 files changed, 5 insertions, 4 deletions
diff --git a/CHANGES b/CHANGES
index b3621f8..1e4eca4 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,4 +1,4 @@
-+ Version 2.15 (??.2016)
++ Version 2.15 (18.10.2016)
- PR #121: Update bundled PLY version to 3.8
- Issue #117: Fix parsing of extra semi-colons inside structure declarations.
@@ -9,6 +9,7 @@
tested).
- PR #145: More complete support for offsetof()
- Issue #116: Fix line numbers recorded for empty and compound statements.
+ - Minor performance improvement to the invalid string literal regex.
+ Version 2.14 (09.06.2015)
diff --git a/README.rst b/README.rst
index 36f3208..f45e5d5 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,5 @@
===============
-pycparser v2.14
+pycparser v2.15
===============
:Author: `Eli Bendersky <http://eli.thegreenplace.net>`_
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index 6585492..da3a295 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -8,7 +8,7 @@
# License: BSD
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.14'
+__version__ = '2.15'
from subprocess import Popen, PIPE
from .c_parser import CParser
diff --git a/setup.py b/setup.py
index fdccbb3..42e2f7c 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
C compilers or analysis tools.
""",
license='BSD',
- version='2.14',
+ version='2.15',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',