summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Bendersky <eliben@gmail.com>2015-04-21 14:48:45 -0700
committerEli Bendersky <eliben@gmail.com>2015-04-21 14:48:45 -0700
commit40af8bdaf34f42c488ea45f98b40c951250bc6d1 (patch)
treecac8bab0324bd35e1776609999f8768d1effbde5
parent331f81f994b3447be17fa93040f6713c02949ec8 (diff)
downloadpycparser-40af8bdaf34f42c488ea45f98b40c951250bc6d1.tar.gz
Prepare for release 2.11release_v2.11
-rw-r--r--CHANGES2
-rw-r--r--README.rst2
-rw-r--r--TODO.txt3
-rw-r--r--pycparser/__init__.py3
-rw-r--r--pycparser/_build_tables.py1
-rw-r--r--setup.py2
6 files changed, 6 insertions, 7 deletions
diff --git a/CHANGES b/CHANGES
index 474011d..d3dab43 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,4 +1,4 @@
-+ Version 2.11 (??)
++ Version 2.11 (21.04.2015)
- Add support for C99 6.5.3.7 p7 - qualifiers within array dimensions in
function declarations. Started with issue #21 (reported with initial patch
diff --git a/README.rst b/README.rst
index fc7190e..6934561 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,5 @@
===============
-pycparser v2.10
+pycparser v2.11
===============
:Author: `Eli Bendersky <http://eli.thegreenplace.net>`_
diff --git a/TODO.txt b/TODO.txt
index e241190..c76b0a1 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -10,11 +10,12 @@ Changes since last
Version Update
--------------
-setup.py, __init__.py, README.txt, CHANGES
+setup.py, __init__.py, README, CHANGES
- Make sure _build_tables was run in pycparser/ and the tables are in the
MANIFEST
- Tag in git. When pushing to GitHub, git push --tags
- If PLY version changes, note it in README and ply/LICENSE
+- Run tox tests
python setup.py sdist upload
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index 86d1c5c..488704d 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -8,7 +8,7 @@
# License: BSD
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.10'
+__version__ = '2.11'
from subprocess import Popen, PIPE
from .c_parser import CParser
@@ -91,4 +91,3 @@ def parse_file(filename, use_cpp=False, cpp_path='cpp', cpp_args='',
if parser is None:
parser = CParser()
return parser.parse(text, filename)
-
diff --git a/pycparser/_build_tables.py b/pycparser/_build_tables.py
index 7cb61ec..e8b5478 100644
--- a/pycparser/_build_tables.py
+++ b/pycparser/_build_tables.py
@@ -11,7 +11,6 @@
#-----------------------------------------------------------------
# Generate c_ast.py
-#
from _ast_gen import ASTCodeGenerator
ast_gen = ASTCodeGenerator('_c_ast.cfg')
ast_gen.generate(open('c_ast.py', 'w'))
diff --git a/setup.py b/setup.py
index 605df08..ee50f53 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
C compilers or analysis tools.
""",
license='BSD',
- version='2.10',
+ version='2.11',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',