summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Bendersky <eliben@gmail.com>2015-05-12 06:06:21 -0700
committerEli Bendersky <eliben@gmail.com>2015-05-12 06:06:21 -0700
commitc5463bd43adef3206c79520812745b368cd6ab21 (patch)
tree7b7b983682e4b5bf82900ac8da92684955e9fa6d
parente460ca8e7bb5da9f5242392606afb3fe45c5ab2d (diff)
downloadpycparser-c5463bd43adef3206c79520812745b368cd6ab21.tar.gz
Update version and CHANGES for 2.13 releaserelease_v2.13
-rw-r--r--CHANGES42
-rw-r--r--README.rst2
-rw-r--r--pycparser/__init__.py2
-rw-r--r--setup.py4
4 files changed, 28 insertions, 22 deletions
diff --git a/CHANGES b/CHANGES
index aa12591..45dce11 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,4 +1,4 @@
-+ Version 2.13 (??)
++ Version 2.13 (12.05.2015)
- Added support for offsetof() the way gcc implements it (special builtin
that takes a type as an argument).
@@ -132,10 +132,13 @@
* Issue 19: anonymous structs & union fields
* Issue 23: fix coordinates of Cast nodes
- - New example added (``examples/c-to-c.py``) for translating ASTs generated by ``pycparser`` back into C code.
+ - New example added (``examples/c-to-c.py``) for translating ASTs generated
+ by ``pycparser`` back into C code.
- ``pycparser`` is now on PyPI (Python Package Index)
- - Created `FAQ <http://code.google.com/p/pycparser/wiki/FAQ>`_ on the ``pycparser`` project page
- - Removed support for Python 2.5. ``pycparser`` supports Python 2 from 2.6 and on, and Python 3.
+ - Created `FAQ <http://code.google.com/p/pycparser/wiki/FAQ>`_ on
+ the ``pycparser`` project page
+ - Removed support for Python 2.5. ``pycparser`` supports Python 2
+ from 2.6 and on, and Python 3.
+ Version 2.02 (10.12.2010)
@@ -145,12 +148,15 @@
+ Version 2.01 (04.12.2010)
- * Removed dependency on YAML. Parsing of the AST node configuration file is done with a simple parser.
+ * Removed dependency on YAML. Parsing of the AST node configuration file
+ is done with a simple parser.
* Fixed issue 12: installation problems
+ Version 2.00 (31.10.2010)
- * Support for C99 (read `this wiki page <http://code.google.com/p/pycparser/wiki/C99support>`_ for more information).
+ * Support for C99 (read
+ `this wiki page <http://code.google.com/p/pycparser/wiki/C99support>`_
+ for more information).
+ Version 1.08 (09.10.2010)
@@ -162,7 +168,8 @@
+ Version 1.07 (18.05.2010)
- * Python 3.1 compatibility: ``pycparser`` was modified to run on Python 3.1 as well as 2.6
+ * Python 3.1 compatibility: ``pycparser`` was modified to run
+ on Python 3.1 as well as 2.6
+ Version 1.06 (10.04.2010)
@@ -172,16 +179,19 @@
+ lexing of the ^= token (XOREQUALS)
+ parsing failed on some abstract declarator rules
- * Linux compatibility: fixed end-of-line and ``cpp`` path issues to allow all tests and examples run on Linux
-
+ * Linux compatibility: fixed end-of-line and ``cpp`` path issues to allow
+ all tests and examples run on Linux
+ Version 1.05 (16.10.2009)
- * Fixed the ``parse_file`` auxiliary function to handle multiple arguments to ``cpp`` correctly
+ * Fixed the ``parse_file`` auxiliary function to handle multiple arguments to
+ ``cpp`` correctly
+ Version 1.04 (22.05.2009)
- * Added the ``fake_libc_include`` directory to allow parsing of C code that uses standard C library include files without dependency on a real C library.
+ * Added the ``fake_libc_include`` directory to allow parsing of C code that
+ uses standard C library include files without dependency on a real C
+ library.
* Tested with Python 2.6 and PLY 3.2
+ Version 1.03 (31.01.2009)
@@ -190,17 +200,15 @@
+ Version 1.02 (16.01.2009)
- * Fixed problem of parsing struct/enum/union names that were named similarly to previously defined ``typedef`` types.
+ * Fixed problem of parsing struct/enum/union names that were named similarly
+ to previously defined ``typedef`` types.
+ Version 1.01 (09.01.2009)
- * Fixed subprocess invocation in the helper function parse_file - now it's more portable
+ * Fixed subprocess invocation in the helper function parse_file - now
+ it's more portable
+ Version 1.0 (15.11.2008)
* Initial release
* Support for ANSI C89
-
-
-
-
diff --git a/README.rst b/README.rst
index 037b1b6..a943c06 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,5 @@
===============
-pycparser v2.12
+pycparser v2.13
===============
:Author: `Eli Bendersky <http://eli.thegreenplace.net>`_
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index 0cc3f83..16c14e8 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -8,7 +8,7 @@
# License: BSD
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.12'
+__version__ = '2.13'
from subprocess import Popen, PIPE
from .c_parser import CParser
diff --git a/setup.py b/setup.py
index 0c53552..f446b62 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
C compilers or analysis tools.
""",
license='BSD',
- version='2.12',
+ version='2.13',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',
@@ -53,5 +53,3 @@ setup(
package_data={'pycparser': ['*.cfg']},
cmdclass={'install': install, 'sdist': sdist},
)
-
-