summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2018-06-28 10:07:31 +0200
committerIlya Etingof <etingof@gmail.com>2018-06-28 10:07:31 +0200
commitf37947f477e7f3b7105e450c89db48a0dcbfd41f (patch)
treef95584a9414b4b117ef71f8c1159ca9362d702b4
parentc59447fd73668d3d5381d091d9c7e525572fb8fc (diff)
downloadpyasn1-git-f37947f477e7f3b7105e450c89db48a0dcbfd41f.tar.gz
bumped up to Python 3.7
-rw-r--r--.travis.yml1
-rw-r--r--README.md2
-rw-r--r--docs/source/pyasn1/contents.rst2
-rw-r--r--setup.py1
4 files changed, 4 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 3d311b7..7784cba 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,6 +8,7 @@ python:
- "3.4"
- "3.5"
- "3.6"
+ - "3.7"
- "nightly"
- "pypy"
- "pypy3"
diff --git a/README.md b/README.md
index fe5ad9a..4b31129 100644
--- a/README.md
+++ b/README.md
@@ -19,7 +19,7 @@ Features
* Generic implementation of ASN.1 types (X.208)
* Standards compliant BER/CER/DER codecs
* Dumps/loads ASN.1 structures from Python types
-* 100% Python, works with Python 2.4 up to Python 3.6
+* 100% Python, works with Python 2.4 up to Python 3.7
* MT-safe
* Contributed ASN.1 compiler [Asn1ate](https://github.com/kimgr/asn1ate)
diff --git a/docs/source/pyasn1/contents.rst b/docs/source/pyasn1/contents.rst
index 102ea87..474bbff 100644
--- a/docs/source/pyasn1/contents.rst
+++ b/docs/source/pyasn1/contents.rst
@@ -20,7 +20,7 @@ implementation of pyasn1 classes from ASN.1 specification.
Both `pyasn1 <https://github.com/etingof/pyasn1>`_ and
`pyasn1-modules <https://github.com/etingof/pyasn1-modules>`_ libraries
-can be used out-of-the-box with Python versions 2.4 through 3.6.
+can be used out-of-the-box with Python versions 2.4 through 3.7.
No external dependencies required.
.. _pyasn1-types:
diff --git a/setup.py b/setup.py
index cea48b9..8a11a34 100644
--- a/setup.py
+++ b/setup.py
@@ -30,6 +30,7 @@ Programming Language :: Python :: 3.3
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
+Programming Language :: Python :: 3.7
Topic :: Communications
Topic :: Software Development :: Libraries :: Python Modules
"""